Everything is red

Hello there. I’ve been using FIJI for image quantification for years and just today, when I went to import a set of TIFFs as an image sequence, the entire image was bright red, like somebody put a red filter over it. Each of the individual RGB color channels was also red. I thought it might have something to do with the FIJI version, since it just updated and when I went to check the version number, I noticed that the background image for “About ImageJ” was also being displayed red. Oddly, apart from that instance, the red color only seems to appear when I import images as a sequence. Opening a TIFF individually works without any problem. I honestly have no idea what’s going on, so I would really appreciate some help with this. Thanks!

1 Like

@CrawlinChaos

Have you tried a fresh, clean installation of Fiji?? I would do this first - before anything… to see if a new download/installation does the trick.

1 Like

Welcome to the forum, @CrawlinChaos!

How are you importing the image? With Bio-Formats? If so, which color mode? If you set it to “Colorized” but it is only a single channel, then image will appear all in red—ImageJ’s default convention for channels is 1=red, 2=green, 3=blue, 4=cyan, 5=magenta, 6=yellow, 7=white. The image can also appear in red when using SCIFIO, depending how you import, and the number of channels in your data, along with your settings. Can you let us know the exact steps you are following?

1 Like

I did delete the previous version from my Applications and download the latest version, but it didn’t have any effect. Does FIJI store other information like Settings or Permissions elsewhere?

I am just using Import>Image Sequence. The .tif files display with all 3 channels, Red/Green/Blue, but all 3 are displayed in red. It doesn’t change if I check “Convert to RGB” and if I check “Convert to 8-Bit Grayscale”, the images don’t open at all. In that case, the Log opens with the following message “No Image: There are no images open”. If it helps, I can provide screenshots and I have the metadata from the images as well.

Fiji/ImageJ does store information in IJ_Prefs.txt. You can find the file here:

MacOSX: /Users/username/Library/Preferences/IJ_Prefs.txt
Windows: C:/Users/username/.imagej/IJ_Prefs.txt

One can reset most of the information by selecting Fiji > Preferences and checking the Clear All Preferences box. I tend to keep a mininal IJ_Prefs.txt file in Dropbox “just in case” I think something in the file could cause issues… If I’m going to do a reset, I save a copy with all the settings in Dropbox…

2 Likes

Hi,

In my experience, importing a G4 compressed TIFF in bio-format will display an image converted to 0, 1 in an 8-bit image. At this time, value 1 seems to be displayed in red. This is a LUT setting, so if you change this to Grays etc, it will be displayed in black and white.
Please try it.

hwada

1 Like

So, I have something going on that is definitely a bug, though I don’t know if its directly related to my other problem. When I was trying to follow the advice from @hwada (thanks!), I tried to “Convert to 8-Bit Grayscale” while doing Import>Image Sequence and it imported some of the images and then stopped, displaying “No Image: There are no images open”. After this, the same error would be displayed when I tried to Import>Image Sequence again, until I restarted FIJI. Mind you that this is all happening after uninstalling FIJI and its preferences and installing a new copy.

Since it might help, here is a screenshot of what the original problem looks like, with the LUTs. I can provide more screenshots or data if it would be useful.

Hi, @CrawlinChaos

Thank you for uploading your screenshot.
In this case, is it possible to change LUT to Glays?
And I have a question.
What the file type did you choose when you saved the image?(8bit, 24bit, 32bit, gray or color scale, compress or uncompress etc.)

What happens if you import using Bio-format?

File>Import>Bio-Formats
Then, select a tiff file.
In dialog, check the check box of “Group files with similar names”.
And click the OK button.

hwada

I changed the LUT to Grays (all equal values for RGB) and all the images in the sequence turned gray. As far as the file type, I believe the .TIFF files are 16-bit color scale uncompressed. Opening the images individually with Bio-Formats does exactly the same thing as File>Open…, which is open the image looking totally normal. That true when I check “Group files with similar names” as well.

However, in your attached picture shows 8bit…
Because I have not use TIFF of 16bit color (48bit color?), I do not know the behavior when opening the file.
Imagine from this window, it may be open in the RGB stack or an array of it.
In the example shown, you may have opened 5 files as an image sequence.

My expectation:
Select “Hyperstack” at “View stack with:” and “Composite” at “Color mode:” in Bio-Fomats Import Options window, they can be opened.
*and also check “Group files with similar names”

hwada

The initial problem was that when I opened multiple files as an image sequence they displayed this red color. Here are few screenshots. The first shows the same image on each side. The one of the left was opened with File>Open, the one on the right was opened with File>Import>Image Sequence, along with all the other images in the folder. The second screenshot shows what I get when I run Image>Get Info for the left and right images respectively. The third shows the File>Open images on the left, the File>Import>Image Sequence on the bottom and the image opened using Bio-Formats Importer with “View stack with: Hyperstack”, “Composite: Color Mode” and “Group files with similar names” applied. I don’t know if the Bio-formats was suppose to open all the images in the folder with those settings, but the 3 images in that stack are the same image

.

Thanks for the details.
I think the case of using BioFormat(on the right hand image) is almost successful.
However, I do not know why not all images are loaded.
*It may be affected by how to put 0 in the serial number part.
And I created a 48bit RGB tiff files and tried converting.
I am going to upload a movie file, please refer to it.

https://signaling.riken.jp/sdm_downloads/48bitrgb-tiff-files-convert-to-hyperstack/

hwada

@CrawlinChaos If you are able to post a sample dataset illustrating the issue, someone (not me right now, unfortunately :frowning:) may be able to dig in more deeply to understand why File › Import › Image Sequence… is displaying the result with a Red LUT instead of Grays by default.

Small update: just by accident, I ended up using Process>Batch>Convert to convert the original .tif to. new .tif files. Yes, a .tif->.tif conversion doesn’t make sense, but like I said, it was an accident. Anyway, when I used File>Import>Image Sequence on the new .tif files, they were all displayed in Grays instead of Red. Any thoughts?

HI, @CrawlinChaos,

Could you see my uploaded movie?
If you open the images using Import>Image Sequence, (The color of LUT at this time does not matter.) please convert the stack image to HyperStack.(Image>HyperStacks>Stack to HyperStacks)
In this time, the value of channels is 3, slices is 1, frames is number of files.
Please tell me what happens if you do it this way.

hwada

This thread was interesting and I appreciate the video. Could you please upload your demo test-01.tif image. I tried to make my own and it did not work as anticipated…

Hi, @John_Minter

Yes, I upload test_01.tif.
test_01.tif (296.6 KB)

hwada

Thank you so much. That was very helpful…

Hello!
I had similar problem, after brightening my pictures in Lightroom Adobe,
I saved them as original format tiff, but after brightening a little it looks red as above.
Any ideas what to do?