Errors and freezing

Tried to work with my TMAs today, but the program keeps freezing and giving errors. Is it memory issues? I have a Macbook Pro with 8GB of RAM.

Thanks and sorry if this is not the correct place for these issues

Could you post the full error log and the script you are running when you encounter it?

I don’t see the standard Java.lang.outofmemory error or whatever it is, but I can’t really see much.

Just happened again. It is occuring when I try to use Positive cell detection. When I try all the cores of TMA, it freezes, so I was trying core by core, and now the error came back and I copied and pasted the whole log below. Hope it helps.
(the log was too long, so I am attaching the file)log.txt (50.9 KB)

Well, that error (the last few errors) doesn’t exactly look like a memory error, but I am still a bit confused about what you are trying to do. I see positive cell detection, but it also looks like you have something that is not a cell selected in the image above.

ERROR: Error running plugin: java.lang.OutOfMemoryError: Java heap space
at java.base/java.util.concurrent.FutureTask.report(Unknown Source)
at java.base/java.util.concurrent.FutureTask.get(Unknown Source)
at qupath.lib.plugins.AbstractPluginRunner.awaitCompletion(AbstractPluginRunner.java:193)
at qupath.lib.plugins.AbstractPluginRunner.runTasks(AbstractPluginRunner.java:157)
at qupath.lib.gui.plugins.PluginRunnerFX.runTasks(PluginRunnerFX.java:94)
at qupath.lib.plugins.AbstractPlugin.runPlugin(AbstractPlugin.java:156)
at qupath.lib.gui.plugins.ParameterDialogWrapper$1.run(ParameterDialogWrapper.java:185)
at java.base/java.lang.Thread.run(Unknown Source)
Caused by Java heap spaceINFO: Processing complete in 169.02 seconds
INFO: Completed with error java.lang.OutOfMemoryError: Java heap space
INFO:

That part is definitely an out of memory error. And just because you have 8GB of memory on your computer doesn’t mean you have given QuPath access to that. Check Help->Show setup options to see whether you are giving QuPath 5-6 GB, though that amount may still not be available depending on how much the OS is using.
image

Edit: Actually, if it is running per core, it might just be failing on each core that has too many objects. I see a few other out of memory errors as I scroll up. Not sure if that could be causing the Hierarchy overlay issues as you try to click on objects that were being created as part of a process that ran out of memory.

Might be an @petebankhead thing to be sure.

There are definitely some out of memory errors happening. There are some tips for handling them at https://github.com/qupath/qupath/wiki/Troubleshooting
In particular, note the bit about Number of processors for parallel commands

The other error looks to be the same as the one here: https://github.com/qupath/qupath/issues/359
It’s really connected to the display of the objects on the image. I’m not 100% sure why it is coming up here, but it may well be connected to the memory errors meaning QuPath was unable to complete a necessary task. In any case, this specific error should be gone in the next release.