Error with search options dialog

Hi everyone! (@ctrueden and @imagejan in particular for this topic)

I just noticed a bug on a freshly installed (just downladed) version of Fiji: when I tried to change the behaviour of the L key from changing focus to the Search Bar to showing the Command Finder (Edit > Options > Search Bar…) I got this error instead of the usual popup dialog:

I found the same issue when tried this in the (updated) Fiji install that I usually run in my laptop (altough the Command Finder shows up as usual, as I had set this behaviour a long time ago). Finally, I tried it on a Fiji distribution that I downloaded back in september (without updates) and it worked just fine:

good%20menu

But it broke right after the first update round, which included:

  • imagej-updater-0.10.2.jar
  • imagej-updater-0.10.3.jar
  • scijava-common-2.76.1.jar
  • scijava-common-2.80.0.jar

So, apparently one of these recent updates accidentally messed up this component, but its hard for me to further pin down the specific culprit.

Any ideas?

Thanks!!

Nico

1 Like

Thanks for the report, @NicoDF.

This bug is fixed in scijava-common 2.80.1, now uploaded to the core update site. It affected all ImageJ2 options plugins, not just the search bar options.

4 Likes

Excellent! Thank you very much for the quick fix!

1 Like

It seems like this affected (or still affects) not only options plugins, but in fact any command that extends DynamicCommand and declares its own moduleService parameter:

1 Like