Error with Export to Spreadsheet

Hey, I’ve been trying to use CellProfiler to segment and count various cell types using a 3D pipeline along with the RelateObjects modules. The pipeline seems to work well in Test Mode, but when analyzing images, I keep getting an error at the ExportToSpreadsheet step:
“Encountered uncrecoverable error in ExportToSpreadsheet during post-processing: Feature Count_CM for Image does not exist.”
As a result, no data is being exported to the spreadsheets. I would appreciate any help on how to get around the error and access the data for the cell counts.

Hello and welcome to the forum. Sorry to hear this!

I would guess the problem lies in an Identify module, the one that finds the objects “CM” but perhaps also the RelateObjects module. You could try a few tests to see whether removing RelateObjects resolves the error, just so we can figure out what’s the cause?

You are welcome to upload a pipeline that produces the error (with the images that are needed to run it) so we can try to reproduce it and see what’s going wrong.

Hi Dr. Carpenter,
It looks like you are right. The RelateObjects module, which identifies the CM objects is giving the error-- when I remove the module, the rest of the program works fine. Is there any way to fix this or get around the error?

You are welcome to upload a pipeline that produces the error (with the images that are needed to run it) so we can try to reproduce it and see what’s going wrong.

Or, you can just play around with the settings or read the help for each setting just to be sure it’s set up properly.

My PI doesn’t want these images to be posted publicly, so would it be possible to send the pipeline and the images to you privately?

I’m sorry, we only like to provide answers publicly so they help others with the problem. But perhaps you can create a tiny crop of an image, or substitute some other image, where you still get the same problem?

No worries-- I have attached the pipeline below.

Pipeline.cpproj (731.6 KB)

And here are the relevant pictures
20Oct2018-h1s1_z001_c004.zip (2.3 MB)

Hello! I have the exact same error when trying to export results, with the error being dependent on the RelateObjects module (when I remove it my other measurements are exported fine). @anishk or @AnneCarpenter have you had any ideas as to where the error is coming from? Thanks in advance for your help!

I could see this error message occurring when using the resulting object of the “RelateObjects” module for measuring later in the pipeline. If you use the non-related objects for measuring the pipeline should run without errors. You will still get the correct number of children within the parent .csv file. If you want to get rid of children without any parent within the pipeline you can always use the FilterObject module and filter for parent number, which is = 0 for spots without parent.

2 Likes

Hi I too am having the same error from RelateObjects and I don’t want to use a different module. Is there another way to fix this error? And to understand what in the RelateObjects module is causing it?

Thanks,
Shimmy

Hi,

I am having the same error message using module CombineObjects followed by ExportToSpreadsheet. If you know the solution to this problem, please help!

Here is my sample images and pipeline to reproduce the error: error_pipeline.cppipe (9.1 KB) A.tif (1.0 KB) B.tif (1.0 KB)

Thanks,
Veronika

Hi @v_saharuka,

Thanks for reporting this, it’s a bug with the new module that I’ve now fixed in the next version.

Sorry for the inconvenience!

1 Like

Hello
I´ve trying analyze some images but also have an error: Encountered unrecoverable error inExportToSpreadsheet during post-processing: Permission denied.
Could someone help me please !!!
Thanks
Berenice

Hi @Berenice_Meza,

Does your CellProfiler installation have permission to access the folder where you’ve set it up to save the files? This may also happen if you have the output file open in another program.