Error with CellProfiler:Analyst Classifier "Score All" function

Hi all,

I’ve been trying to get this pipeline (i.e. classify treatments that would induce lipolysis in adipocytes) of mine to work. So far, CellProfiler has worked fairly well to get to where I need to get to (CellProfiler Analyst). My use for CPA was to
A.) To classify which cells would be differentiated
B.) To compare lipid droplet size (i.e. increase/decrease) when compared to control.

When I try to classify and score cells I always run into errors when I attempt to “Score All”. It never fails to give me the following error:

42

So, I’m a little confused as to how to precede in using CPA for quantification purposes. At the moment, I’m re-running my CP pipeline where I’ve changed the perimeters of my ExportToDatabase module to produce a “table per object type” thinking that might alleviate the issue. As for now, any help or guidance will be useful (will provide properties file and pipeline as well if needed).

Hi there,
We always like helping nice scientists :slight_smile:

I’m not an expert on this, but it appears to me to be a problem connecting to the database where your data is stored. Are you offline, or disconnected from some server where the data is?

I’m doing this from an SQLite server!

I’ve also tried to do a single table per object to no avail. I have my properties.table also if that would help.

Do you mind trying the example one? http://d1zymp9ayga15t.cloudfront.net/content/Examplezips/cpa_2.0_example.zip

One thing it could be (if indeed it’s a ‘connection’ problem) is that the files you’ve created don’t have read access or permissions or something. But that’s just speculation, I don’t know much about this part of CPA.

Thank you so much!

I’ll try this, compare with my own to see what could be going wrong and report back!

1 Like

Hi there.

Just a brief update. It seems I found a work around to my issue by re-running my pipeline out on CellProfiler 3.1.8 because of the bugfixes that were implemented. It would also seem that that has allowed me to actually use Analyst without the issue of the database being locked. Since I have multiple objects of interest, that are not in a one-to-one relationship, I had export them with the option “one table per object”. It would seem as though that fixed it as I am able to see the enriched scores. Still, however, I get an error that is a big wall of text that I cannot recreate.

Can you take a screenshot?