Error while submitting the process



Dear Team,

Following is my machine’s architecture
Linux dewar 2.6.9-67.0.15.ELsmp #1 SMP Tue Apr 22 13:58:43 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

I have installed CellProfiler on this Linux machine after lots of hassels like libraries, env variables etc…
Now, when I’m running my process on it after putting all variables, it gives me the following errors…

??? Undefined variable “com” or class “com.mathworks.timer.TimerTask”.
Error in ==> mltimerpackage at 9
Error in ==> timerfind at 57
Error in ==> CellProfiler>AnalyzeImagesButton_Callback at 9128
Error in ==> CellProfiler>gui_mainfcn at 11138
Error in ==> CellProfiler at 55
??? Error using ==> CellProfiler(‘AnalyzeImagesButton_Callback’,gcbo,],guidata(gcbo))
Undefined variable “com” or class “com.mathworks.timer.TimerTask”.
??? Error while evaluating uicontrol Callback

Kindly let me know, how to solve this one. This time, its beyond my understanding to solve it though I can feel it.
Plz, help me out.
Mridul KK


Hi Mridul,

This is a Matlab issue on Solaris machines. The describes the problem here: … A1NES.html

Let me know if you need additional help.



Hi Kate,
I tried whatever is suggested in the Mathworks page but the bug is still there.
Can you be able to help me out. This is the last problem, I guess I’m facing before perfect running of CP on my images.
Rest all problems have been solved.

Thanks for your understanding.
Mridul KK


Hi Mridul,

I’m not sure why this is happening, but I would just double check that the LD_LIBRARY_PATH is looking for the MCR in the right place- make sure the $MCRROOT is the same place you unzipped the MCR, in other words.

Mathworks claims this has been fixed in the new version of Matlab that we used to compile the newest version- which should be out soon.



Hi Kate,
I have unzipped the CP in home directory i.e /home/CellProfiler…
Within this directory, I have unzipped the MCR directory which is named as ‘v76’ in the CP package.

I set the path of LD_LIBRARY_PATH = /home/CP…/v76/bin/glnxa64/
and MCRROOT = /home/CP…/v76/

On starting the CP, it runs. I’m able to load the pipeline and set all preferences.
But when I submit the process, that is ‘Analyze images’ button…
a blank status window comes up…no windows are displayed (selected windows option used) and finally gives a error which I already posted.
A additional message is pasted below, which may help you…

   Segmentation violation detected at Wed Sep 10 11:00:36 2008

MATLAB Version: (R2007a)
MATLAB License: unknown
Operating System: Linux 2.6.9-67.0.15.ELsmp #1 SMP Tue Apr 22 13:58:43 EDT 2008 x86_64
GNU C Library: 2.3.4 stable
Window System: The X.Org Foundation (60802000), display :0.0
Current Visual: 0x21 (class 4, depth 24)
Virtual Machine: Java is not enabled
Default Charset: UTF-8

Register State:
rax = 0000000000000001 rbx = 0000000000000000
rcx = 0000003ae442e783 rdx = 0000000000000000
rbp = 0000000000000000 rsi = 0000000000000001
rdi = 0000002a95cfcc80 rsp = 0000000000000000
r8 = 0000000000000000 r9 = 0000000040a00960
r10 = 0000000000000008 r11 = 0000003ae510ae40
r12 = 0000000000000000 r13 = 0000000000000000
r14 = 0000000000000000 r15 = 0000000000000000
rip = 0000000000000000 flg = 0000000000010202

Stack Trace:

So, is my path settings has some problem or anything else, I need to do.

Stuck-up badly at crucial time of results for a conference.
Thanks for taking up the issue immediately.
Mridul KK


Hi Mridul,

I think it must be the path settings, because the file it is looking for is in the deployed version. Give this a try:
setenv XAPPLRESDIR mcr_root/version/X11/app-defaults



Hi Kate,
This was an awesome help from you.
It really worked and I’m so happy to run it successfully.
Thanks for your continous support.

Kate, I dont know how much you are familiar with analysis stuff but just want to ask you incase you can suggest something.
I’m doing an analysis for nuclear-translocation assay and under the condition when no stimulation was given for the protein to be translocated into the nucleus (Green floroscence protein)…I’m getting the following measurements for Avg. Intensity of CorrGreen and CorrBlue in different objects. I have attached the measurements as jpg files.
Cam you just have a look on it (specially Integrated and Mean Intensities) and say, whether this pattern of measurements is right or not?

Once again, thanks a lot for yr kind and timely help.
Mridul KK


Most likely, for a nuclear translocation assay you will want to use CalculateRatios to calculate the ratio of intensity in the nucleus divided by cytoplasm (or vice versa). The measurement you would want to use for this is either Mean Intensity or Integrated Intensity (try both, sometimes one is better than the other). Also try the log of the ratio - sometimes that is better than linear scaling. For others reading this post, see the previous post here about using CalculateStatistics to decide which of several possible measurements is the best for an assay, and more details on cytoplasm-nucleus translocation in particular:

Looking over the measurements for a single image is not likely to help determine whether the image analysis is ‘working’ or not - you’d want to look at measurements for a positive and negative control side by side, or even better look at multiple positives and negatives using CalculateStatistics.