Error while stitching images

Hello,

I am using the Stitching pluggin from Preibisch 2009. I used it in the past and had no isue with it. I recently tried to use it on new images and I am having some trouble. Some of the log :

7.tif[1] <- 8.tif[1]: (900.0, -4.0, -1.0) correlation (R)=0.11532007 (60258 ms)
8.tif[1] <- 9.tif[1]: (901.0, -6.0, -3.0) correlation (R)=0.23027366 (52390 ms)
6.tif[1] <- 9.tif[1]: (-63.0, 923.0, -9.0) correlation (R)=0.23315607 (37490 ms)
ERROR: Error: No correlated tiles found, setting the first tile to (0, 0, 0).
 number of tiles = 1
Finished registration process (232089 ms).
1.tif: [1,3](0.0,0.0,0.0) 1.7976931348623157E308

The pluggin seem to be able to compute the relative positions of the tiles, however it fails when it is supposed to fuse them.

Do you have any idea how to solve this issue ?

(I tried to rerun the stitching on previously acquired images and everything seemed to be fine, but the new images still won’t work :confused: )

Many thanks,
Corentin

Hi @C_M,

Do the new images have any obvious format difference with the previous ones?

Nico

Complete shot in the dark, but the R values for the correlations seem very low, which fits with it not finding correlated tiles. I would check whether the expected overlap (*distance), if any, is accurate. Alternatively, if the numbering scheme on the TIFFs is relevant to their position, use that instead with no overlap (if there is no overlap).

1 Like

Welcome to the forum, @C_M!

You might want to try lowering the Regression threshold parameter (default = 0.3), although this might lead to undesired (wrong) tile matches.

See also the documentation on the wiki:

2 Likes