Error while processing ExportToDatabase




I’m try to create a properties file to use for CPA. I tried using the module ExportToDatabase at the end of my pipeline that tracks cells and uses the MeasureTrackQuality module. I am getting a couple of errors.

Before I start the run, the ExportToDatabase module gives me a warning Nuclei is not in a 1:1 relationship with other objects. Does this have to do with the fact that I am analyzing tracked cells rather than all cells identified in any single image?

Then, if I try to Analyze the Images, I get the Key Error: u’Mean_Filtered_Nuclei_MeasureTrackQuality_Is_Parent.

Am I looking at 2 different problems here? Any help is highly appreciated. thanks in advance!


I think you may have two separate issues- the first can be solved by setting Export measurements for all objects to the database? to “Select” and picking only your tracked objects.

Can you try fixing that and see if you still get the error? If not, please upload your pipeline and a set of images we can use to try to reproduce.


Thanks. The warning I was getting associated with the ExportToDatabase is gone, so the first problem is solved. I still get the Key error when I run the pipeline. I am uploading it along with a small set of images. Thanks for looking into it!!

TA_CP_PipelineExampleSet.cpproj (1.1 MB)