Error when updating Fiji - FileNotFoundExeption

Hi guys,

I tried to update my Fiji (Win7 , 64bit) today and when i restart i get an error:

Does anyone has similar issues or is it just me?

Hello Sebi,

I do not see the error you see.

I am running on 64-bit ubuntu 16.04 LTS. My ImageJ was at
version 2.0.0-rc-65/1.5w; Java 1.8.0_66 [64-bit];

I launched ImageJ and permitted it to auto-update. It updated
six files – one TrackMate file and five bioformats files. It reports
the same version of ImageJ as before. I can restart it and launch
it (repeatedly) just fine.

I notice that your error complains about ij-1.51s.jar. I don’t really
know how the versions work, but that seems to be several letters
out of date compared to what I see as the current ij version, so
perhaps that is a hint.

Thanks, mm

http://sites.imagej.net/EMBL-CBA/

This looks to me like an issue specific to the EMBL-CBA update site. Indeed, there is no file ij-1.51s.jar-20180313153931 in http://sites.imagej.net/EMBL-CBA/jars/ (@sebi06 did you try disabling this update site?)

I took a look at the db.xml.gz file of that update site, and it contains an entry:

<plugin filename="jars/ij-1.51s.jar">
        <version checksum="a0c5ec5607bf859bc1714be19c6abf950ef5c2ce" timestamp="20180313153931" filesize="2223326">
...

So it seems that either:

  • the file was present at some point and then got manually deleted (instead of using the ImageJ updater to do so), leading to a broken state of the update site, or
  • something went wrong the last time someone wanted to upload files to that site (in this case it would be helpful to have the error log…)

In any case, let’s ask the maintainer of that update site: @Christian_Tischer, do you have a clue about this issue?

I tried to disable that site but the updater does not start anymore. Instead the error pops up.

Hello!

When running the updater I indeed have this message:

I don’t know yet why this file is there. Probably some strange dependency of one of my projects somewhere. I will have to find out!

I will try now Mark obsolete (My Site). I hope that is the right thing to do?

I just downloaded a fresh Fiji, added EMBL-CBA update site, updated and everything runs fine.
Hopefully for you, too?

I wonder how it happened that ij.jar ended up in your db.xml. Could it be that you uploaded at some point without first checking that your Fiji installation is up to date (i.e. getting all updates from all other update sites before uploading stuff)?

Maybe you can disable the update site when running the updater from the command line?
Also, maybe @ctrueden has some idea how to fix your installation…

I think the problem is that one of my projects has (for some unknown) reason the dependency to the ij-1.51s.jar. Whenever I update my Fiji it asks me how to resolve the conflict between the ij-1.51s.jar and whatever the latest version is. Probably I once clicked to keep the old one rather than replacing it with the new one. Does that make sense?

1 Like

Thanks @imagejan for the detective work. It looks like EMBL-CBA is no longer shadowing an ij.jar. But just to be sure, I diffed the entire ij.jar plugin record history against the one on the core ImageJ update site. The only additional entry was this weird version of ij-1.51s.jar which is not the canonical one. I moved that entry onto the ImageJ update site, just in case anyone has that file lying around locally somehow (so that it gets flagged for update instead of “locally modified”). And then I deleted the whole <plugin> history for ij.jar from EMBL-CBA. Please let me know if anything is not working.

2 Likes

Dear all,

I was informed today that our update site gave a similar problem and I could reproduce it on my own computer.

“java.io.FileNotFoundException: http://sites.imagej.net/Fuellekrug-Lab/plugins/Watershed_.jar-20181102150850”
There is no such file. The first entry of this plugin is Watershed_.jar-20181105233331

I got the same window as sebi, the guy who told me the error in the first place had this console-error:

[Mon Apr 01 16:22:36 CDT 2019] [ERROR] [] null

java.io.FileNotFoundException: http://sites.imagej.net/Fuellekrug-Lab/plugins/Watershed_.jar-20181102150850

                at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

                at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)

                at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)

                at java.lang.reflect.Constructor.newInstance(Constructor.java:422)

                at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1890)

                at sun.net.www.protocol.http.HttpURLConnection$10.run(HttpURLConnection.java:1885)

                at java.security.AccessController.doPrivileged(Native Method)

                at sun.net.www.protocol.http.HttpURLConnection.getChainedException(HttpURLConnection.java:1884)

                at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1457)

                at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441)

                at net.imagej.updater.util.Downloader.download(Downloader.java:117)

                at net.imagej.updater.util.Downloader.start(Downloader.java:98)

                at net.imagej.updater.Installer.start(Installer.java:154)

                at net.imagej.ui.swing.updater.UpdaterFrame.install(UpdaterFrame.java:629)

                at net.imagej.ui.swing.updater.UpdaterFrame$13.run(UpdaterFrame.java:566)

Caused by: java.io.FileNotFoundException: http://sites.imagej.net/Fuellekrug-Lab/plugins/Watershed_.jar-20181102150850

                at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1836)

                at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441)

                at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(HttpURLConnection.java:2943)

                at java.net.HttpURLConnection.getHeaderFieldDate(HttpURLConnection.java:552)

                at java.net.URLConnection.getLastModified(URLConnection.java:559)

                at net.imagej.updater.util.Downloader.download(Downloader.java:108)

                ... 4 more

I re-uploaded the Watershed_.jar, disabled and enabled the update site and this fixed the problem for now, altough I needed to repeat it a couple of times before it worked stably.

Is there a solution to this by maybe deleting and re-uploading the files?

Thank you very much!

That file exists on the update site called TExner. Is it possible you had the TExner update site enabled when you uploaded your own version of the Watershed_.jar file to the Fuellekrug-Lab update site? If so, the metadata of the update sites may have gotten mixed together.

As a rule, when uploading to your update site, do not enable any other update sites besides what your site depends on (typically ImageJ, Fiji, and Java-8). Otherwise, this confusing problem can happen. I’m sorry this is probably not clear in the documentation—edits to improve the situation are warmly welcomed.