Error when trying to save classes for each object in database




I am using the classifier, it works well.
I have 4 classes named:

But once I am done and I want to save in database a class for each of the object I have the following error:

data too long for column ‘class’ at row 1. So I checked the class_table in the database and the ‘class’ column is supposed to be a varchar(3).

The class_table remaines empty after that.

The thing is I don’t understand what to change because the default name of the bins are ‘positive’ and ‘negative’ which have more letters than the class name I have so the problem is not coming from that.

Do you have an idea what I could change?

Thank you,


Hmm, that’s definitely odd! Can you post it as a bug here with enough information to reproduce it?

In the meantime as a workaround, you can save class table as a CSV using File-> Save table to CSV then re-import it into your database- most SQL interaction programs should have a way to do this.

Sorry for the inconvenience!



Sorry I didn’t reply earlier.
I just tried to changed the name of the class few time and finally decided to put numbers. And that worked.
The fact is that the column “class” and “classNumber” have the same information but “class” is only a varchar(3). Therefore it is not possible to put name like “initial”, “final” as class names.

Maybe that is something already changed in the new cellprofiler/cellprofiler analyst version.

Thank you,
Solène Weill