Error when trying to open CellProfiler Analyst

I just downloaded the latest version of CellProfiler Analyst and have been trying to run it, but I keep getting this error when I go to start the program. I have uninstalled and reinstalled the software a few times and restarted my computer, but I still get the same error message.

Does anyone know how to fix this?

Can you try to “Run as Admin”? A hidden log file is trying to write to your Program Files directory and apparently you don’t have access.

Okay, I tried that just now. It popped up a dialog saying an error had occurred and to check the log for details. The log was able to be written this time and it said the following:
No handlers could be found for logger "javabridge.locate"
Traceback (most recent call last):
File “”, line 19, in
File “javabridge_init_.pyc”, line 28, in
Copyright © 2009-2013 Broad Institute
File “javabridge\jutil.pyc”, line 137, in
the script has run, the values of these
File “javabridge\jutil.pyc”, line 125, in _find_jvm

javabridge.jutil.JVMNotFoundError: Can’t find the Java Virtual Machine


CPA requires Java SE Runtime (JRE). Maybe try to (re)install Java for your machine?


I reinstalled the latest version of Java and still get the same error.
Does anyone have one of the previous versions of CPA, because I got a slightly older version to run for me. It just asked if I wanted to update, as soon as I ran it, so now I’ve lost that older working version.
Does this latest version of CPA run for you?

I found the older version downloads and the most recent version I can get to work for me is 2.0 r10530.

I’m having the same issue. I no longer get an error message - the windows just disappear once I’ve selected the properties file

Can you verify the Java version that you are using? You can have more than one installed and CPA may not be defaulting to the version you think.

Can you all report the output of
java -version
(or whatever equivalent on Windows?)

My output (for a nightly build from a few weeks ago at least) which works is:

$ java -version
java version "1.8.0_92"
Java™ SE Runtime Environment (build 1.8.0_92-b14)
Java HotSpot™ 64-Bit Server VM (build 25.92-b14, mixed mode)

It won’t let me copy and paste but it says:

java version "1.8.0_91"
Java™ SE Runtime Environment (build 1.8.0_91-b15)
Java HotSpot™ Client VM (build 25.91-b15, mixed mode)

What version of Windows are you using? Is that Windows 10 already? I’m just curious…

Yes, I am using Windows 10.

I finally got it to work. I downloaded and changed my java to the 64 bit version, and it runs now.


I had the JVMNotFoundError with CellProfiler.

The solution was to set JAVA_HOME. In our case, Java is installed in
C:\Program Files\Java\jdk1.8.0_112
C:\Program Files\Java\jre1.8.0_112

So I set:
JAVA_HOME=C:\Program Files\Java\jre1.8.0_112

1 Like

Can you try to Run as Admin?

I tried to use CPA again today, and encountered this issue. I don’t see an error window, but the program closes as soon as I select the properties file - I don’t even get to the CPA interface.
I’ve downloaded the most recent java version, but I’m not sure how to set java_home as hajaalin did. Did you literally type JAVA_HOME=… into the console?
My java version:
java version "1.8.0_112"
Java™ SE Runtime Environment (build 1.8.0_112-b15)
Java HotSpot™ 64-Bit Server VM (build 25.112-b15, mixed mode)

I’ve tried running as admin, which made no difference
I’m using Windows 7. Any help would be appreciated!

Have you checked the log file? It should be located wherever you installed CPA? I’ve had this issue before, where I was pointing to a sql file (in the properties file) that didn’t actually exist. This happens if you move any of the files from where they were first written to.

If you don’t get an error window, it means your installation is fine but that’s something’s wrong with your properties file and/or database. If you have trouble tracking down the error, see if you get it to work with a preconfigured example such as this one.

Thanks Beth!
I made a new properties file and now it seems to be working fine.

1 Like

Thank you for the inspiration.
r10530 wasn’t listed, but r10415 did the trick.

I have same problem in using weka in my python code which describeit in this link.

would you please help me?