Error "ordinal not in range(128)



Hi all,
I am facing a problem when using CellProfiler 2.2.0. I have my pipeline (Analisis_yap.cpproj) and, when I upload it into the program, I get the following errors:


Any ideas of how to solve them? It allows me to keep on analyzing if clicking in “Continue processing”, but then I encounter a new error in the processing of each image.

I think there is something wrong on how the program is loading the metadata. I looked for the ‘u/xed’ character and it is an í, which was in my previous path, but then I changed the images to a new one. However, the error is still the same.

My pipeline is this one: Analisis_yap.cpproj (466.1 KB)

Thanks you all,



Hello Marina,
Have you tried recreating this pipeline in the new CellProfiler 3.0? This might require some adjustments since some modules were renamed, merged or separated.
It could be 2.2.0 bugs that were fixed in the new 3.0 version.


Is the “Default Input”, “Default Output”, “Plugins”, or any other CP-designated folder set to something with a non-ascii character in it?


Hello Vchernys,

In fact, I’m using the 2.2.0 version and this is a pipline also created in this version.


Hello Bcimini,

It was but I already changed it, the problem is that apparently the cell profiler don’t recognieze the change.