Error Message when using DiameterJ

Hello, I am getting an error message when I’m trying to segment my image prior to measuring the diameter in DiameterJ. error%20message

This image is from one of the the training tutorials, but also occurs when I try to use my own image as well. All images are in 8-bit and are .tif files.

I’m not sure what reader plugin I’m missing or exactly what is means by file not found. Any help would be extremely appreciated.

Thank you.

Could you walk us through the process that produces this error?

I downloaded ImageJ, then downloaded DiameterJ according to the instructions of extracting the files from the zip folder and pasting them into the Plugins folder for ImageJ. I open Image J. Since I’m only trying to segment one image, I open that image. Make sure it’s in 8-bit. I open the Plugins drop down menu, select Diameter J Segment (I have both 1-017 & 1-018-- both give me the same error message). The basic Information screen opens, I set the cropping coordinates accordingly.

See below for the segmentation algorithms. But after hitting okay, I choose the directory where I want my images stored then another window pops up with the Log and the error message.

For segmentation algorithms, I’ve tried 1. just checking traditional, nothing else. 2. Leaving the boxes that are already checked. (Stat region merged and mixed). 3. none. 4. Just SRM. All possible combos give me the same error message.

I hope this is clear!

For analyzing more than one image, I select No.

Hello @kml2013,

Which version of ImageJ did you download? Have you tried running the plugin in Fiji instead of vanilla ImageJ?


:coffee: :computer:

Hey @AndyMan,

I’m running version v1.52d. I’m updating to v1.52e now so I’ll see if that works. But I will also look into Fiji.

Thank you,

Where did you download it from? It seems unusual but there appears to be separate versions for Fiji and ImageJ (see here). I just tried it with my installation of ImageJ 1.50b and had no issues.

hey@kml2013,have you solved this problem,I faced same problem like you,and i dont know how i can deal with it. If you solved this problem, could you tell me how to solve it.Thank you very much

I am also facing the same problem. Have you find any solution for this?

@qin2018 @Tapas_Dora Have you found a solution? What have you tried so far?

I’m having the same issues as well… I’ve redownloaded the latest ImageJ version from Fiji and installed the Diameter J Plugin. However,I keep getting these error messages whe I attempt to segment my images. Any suggestions?

I have the same issue and need help badly on this. I have tried a lot of the version, now on Fiji and its giving me same error as Lawrence, so frustrating Please anybody to help

I believe the solution I posted here will solve many of these problems. DiameterJ will not run segmentation or analysis plugin

Additionally, I heavily recommend using FIJI/ImageJ2 for compatibility with DiameterJ.

(EDIT: I previously incorrectly stated that ImageJ1 was no longer under development which Herbie pointed out is actually wrong, Thanks Herbie! I didn’t know.)

ImageJ is no longer in active development.

This is definitely not true or we have different ideas of what active development means. See the recent additions (concerning e.g. plotting) and not only the bug-fixes.



Hah, yes you are correct. Sorry, that was a WAY over simplified statement. Classic ImageJ1, is no longer actively developed. ImageJ2 however, is of course still actively developed as its the base for FIJI. Sorry for the incorrect statement.

No, Classic ImageJ-1 is definitely actively developed and Fiji in certain respects still depends on ImageJ-1 code.

What actually the basis of Fiji is, can be discussed.

There you are sir, apologies. I was wrong. As an aside, I think your bolded text was links to prove your statement… but they don’t show up as links… just bolded text for me.

It is bolded text only, but here is a list of 6 additions or improvements (not bug-fixes) to ImageJ-1 that took place during the past month:

  1. Thanks to Albert Cardona and Gabriel Landini, added the “GUI scale (0.5-3.0)” option to the Edit>Options>Appearance dialog, which enables scaling of text in GenericDialogs and in the Command Finder. It also doubles the size of the tool icons if the scale is 1.5 or larger and triples the size if the scale is 2.5 or larger.

  2. Thanks to Norbert Vischer, added clickable spaces between the four arrow pairs in plot windows for quickly setting a single plot limit.

  3. Michael Schmid contributed an improved version of the ThresholdToSelection class (Edit>Selection>Create Selection) that always converts single pixel wide lines to traced selections and is up to five times faster.

  4. Michael Schmid contributed the FloatArray class, an extendable float array.

  5. Thanks to Norbert Vischer, added the Table.setSelection(start,end,title), Table.getSelectionStart(title) and Table.getSelectionEnd(title) macro functions (example).

  6. Added the setOption(“ScaleConversions”,boolean) macro function.



Yes, you were right and I was wrong. Not to nitpick but if, in the future, you’re going to take the time to bold a statement for emphasis, its more convincing (in my opinion) to just link proof of your statement, rather than bold. I’m not trying to start a flame war, I was unequivocally wrong.

As an aside, I’m not sure if you can see the edit to the original post or not, I got a message about it needing review because I edited several times quickly. I hadn’t checked in with the ImageJ1 community in over a year and had stopped getting email updates so I thought they had switched over to ImageJ2. But that turns out has to do with an email password expiring. Sorry for the incorrect initial statement. It has been edited to reflect a more accurate statement.

Hello all, I am facing the problem that I copy the folder with DiameterJ in the plugins folder and I do not see DiameterJ in the plugins menu. Moreover, I installed the plugin and again it will not appear in teh menu. I have downloaded Fiji and the version is ImageJ 1.52. I do not know if I have to download another version since the Skeleton Intersections and OrientationJ can be seen in the menu. Thank you