Error loading pipelines - Cellprofiler 4.0.7 Windows

Hello,

I have recently downloaded and installed Cellprofiler 4.0.7 for Windows and I am using it in my project to analyse microscope images. Building a pipeline and executing it works all very nice, and I can even export pipelines. However, I have an issues importing pipelines and always get the following error message :
image011
“Error”
Without any further details. But no pipeline is loaded.

Another problem is that I cannot save projects. No error message is displayed, but no file is created after I try to save the Project.

Regardless if the « .cppipe » has been exported by myself or just downloaded from the examples on your website, I am always unable to load pipelines from files.

This makes it of course very difficult to work, as I need to rebuild the pipeline every time I close and reopen CellProfiler.

My version is 4.0.7, downloaded from your website.

I am using Windows 10.

I have Anaconda Python 3.7 and openjdk 1.8.0.222-2.

Hmmm, that’s definitely very unusual! Sorry to hear that.

Since it looks like you may be on Windows, when you see that error again can you check the black terminal screen that launches with CellProfiler, to see if there is any extra information in the full error trace? (Best would be if you could copy and paste the text directly here). That should help in trying to track the issue down.

Hello Beth! Thanks a lot for your reply.
Ok, so I open CellProfiler and just try to import a pipeline from file. I get the little window with the error message that I’ve shown you in my previous message.
In the black terminal, nothing is displayed:

Then I load an image and add 1 module to the pipeline (it works if I execute it).
Then I try to save the project and I get the following error message in the black terminal:
image

If I try to open an existing project, I get:

And when I run the analysis with this simple pipeline (just 1 image set called CPS and 1 module “IdentifyPrimaryObjects” without advanced settings), it performs the analysis correctly, displays the window with the result, displays the window with the message “Analysis complete”, but in the black terminal it adds these lines:

Thanks a lot again for your support.

Hi @MatteoF,

It looks like CellProfiler is having trouble writing to the temporary file which CellProfiler uses to store measurements during a run. Could I check that you have full administrator permissions on the machine this is running on and that CellProfiler has permission to write to the system disk?

Hello @DStirling. Thanks a lot for your suggestion.

I have been assigned administrator permissions on the machine and the permission to write on system disk, and I get the same errors. Nothing has changed. I have even tried to run CellProfiler as administrator and it doesn’t change anything in the behaviour described above.

Here is a screenshot of the Properties Window (tab “Security”) in the default folder where CellProfiler writes the temporary files.
image

Kind regards.

Is it possible that there are any characters with accents, etc, in the path? In CellProfiler 2 and 3 that sometimes caused an error (a different exact error than what you’re posting, but similar). We thought we had this accounted for in CellProfiler 4 but it’s possible that we missed something.