Error: index out of bounds


I am using the module IdentifyObjectsManually in order to identify certain nuclei on my images. During the manual selection it appears “IndexError: index 1414 is out of bounds for axis 1 with size 479”. After this I can not continue my selection. How can I avoid this? Thanks.

Maria Henriques

Hi Maria,

What version of CellProfiler are you using? That seems similar to a bug that was fixed a few years ago, so I’m wondering if perhaps it’s an old version and simply upgrading would fix the issue.

Otherwise, please provide us your OS, what version of CellProfiler this is happening in, under what circumstances you’re getting this error (is it when you’re drawing? Trying to erase? etc) and a pipeline and sample images to help us troubleshoot the issue.


I am using Cell Profiler: Stable (2.2.0). There are a latest version? This happens when I am drawing, more specifically, when I finish to draw the nuclei and I release the mouse button. Actualy, now I am able to keep drawing if I use another way to draw my nuclei (for example using the editing command N, which creates a new object under the curser). However, once in a while the error keeps appearing.


I am receiving essentially the same error. I downloaded the current version of CP and am using a set of plates from Neil Carragher’s Molecular Cancer Research paper from the BBBC as a teaching case study.

The error message is: Error while processing MeasureObjectIntensity:
(Worker) IndexError: index 86 is out of bounds for axis 0 with size 86

I get the error about 30 times for 240 image sets. I can continue the run and it completes but when I open the data file, it appears that the pipeline can count the nuclei, but all area-shape measurements are NaN, but ironically, the intensity measurements are reported.


To add: I am using the assisted object identification (typical nuclei pixel size measurements in Identify Primary Objects) and am operating this on a Mac.


Have exactly same issue on Win10 with version of CP3.1.5. I’ve tried to install older versions (3.0 and 2.2) however those can’t find JVM and fail to start.

Could this issue be fixed once and for all? It seems that every year since 2011 it comes back.

Hi Steve and Anton,

Your issue is actually a different one, one that should be fixed in our next release (hopefully next week!)

Anton, your issue with the JVM should be able to be fixed by fixing some environment varibles, sorry for the inconvenience!