Error in triangulate

I was trying out the new 3d feature and everything worked fine up to checking for undistortion. However, once I run triangulation, it gives me the following error (attached in screenshot). The 2D analyses seem to be done correctly but it then runs into an error that I’m not sure what’s causing it. Does anyone have an idea what might be going on here?


Also, this is what the config.yaml file looks like:

Project definitions (do not edit)

Task: reaching_3d
scorer: ijang
date: Jun27

Project path (change when moving around)

project_path: /home/ijang/reaching_3d-ijang-2019-06-27-3d

Plotting configuration

skeleton: # Note that the pairs must be defined, as you want them linked!

    • Digit1
    • Back
    • Digit3
    • Back
    • Digit5
    • Back
    • Back
    • Wrist
    • Wrist
    • Elbow
      skeleton_color: black
      pcutoff: 0.4
      colormap: jet
      dotsize: 4
      alphaValue: 0.8
      markerType: ‘*’
      markerColor: r

Number of cameras, camera names, path of the config files, shuffle index and trainingsetindex used to analyze videos:

num_cameras: 2
camera_names:

  • camera-1
  • camera-2
    scorername_3d: DLC_3D # Enter the scorer name for the 3D output
    trainingsetindex_camera-1: 0
    trainingsetindex_camera-2: 0
    config_file_camera-1: /home/ijang/reaching_top-ijang-2019-06-25/config.yaml
    config_file_camera-2: /home/ijang/reaching_left-ijang-2019-06-18/config.yaml
    shuffle_camera-1: 1
    shuffle_camera-2: 1

looking into it! :slight_smile:

we will make a small fix for this and push 2.0.7.1 asap! thanks for the catch.

Also, just as a tip, but in the future you might want to make your scorername_3D scorer name more meaningful to be able to know which project you used to analysis the data; i.e. if this was my project, I would call it: ijang_reaching_3d or such :slight_smile:

1 Like

We pushed to the repo: https://github.com/AlexEMG/DeepLabCut
Can you please clone + reinstall and see if that fixes your issue?

1 Like

Thank you so much for all the help! I’ll try it once I get back to work tomorrow

Hello. thank you for creating amazing toolbox!

I got the same error as ijang’s and this was solved by installing ver 2.0.7.1.
The both 3d functions (triangulate and create_labeled_video_3d) worked!

But the following error was returned when I changed “save_as_csv” option in triangulate function.

dlc.triangulate(config_path3d ,video_path, videotype=‘avi’, save_as_csv=True)

Computing the triangulation…
Traceback (most recent call last):
** File “”, line 1, in **
** File “/home/hiroshi/.pyenv/versions/3.6.8/lib/python3.6/site-packages/deeplabcut/pose_estimation_3d/triangulation.py”, line 215, in triangulate**
df_3d.to_csv(str(output_filename+’.csv’),‘df_with_missing’,format=‘table’, mode=‘w’)
TypeError: to_csv() got an unexpected keyword argument 'format’

If save_as_csv=False, everything worked well.

1 Like

Just released as https://pypi.org/project/deeplabcut/2.0.7.1/

Thanks for the feedback!

Everything worked great, thank you so much!