Error in opening Example pipeline

Hello,
I have been trying to open the “Speckle counting” pipeline in CellProfiler v4.1.3 but it is not opening. It is showing that ‘The pipeline cannot be started because of a configuration problem : The pipeline did not identify any images set. Please correct any problems in your input module settings and try again.’
Previously I tried opening the same example pipeline in v3.1.9 but it failed to open mentioning that I need to update to a newer version. How to solve this issue?

1 Like

Hi @Shalini,

Welcome to the image.sc forum! We’re happy to help.

I just checked out the Speckle Counting pipeline and it’s working in my version of CellProfiler. Did you add the images folder contained within the ExampleSpeckles folder to CellProfiler? Initially, there’s a large white square in the lower right corner of CellProfiler that says “Drop files and folders here”

You can drag and drop the images folder onto that box and then you should see the images listed:

Once that is configured, test mode should run without errors. You may find our introductory videos helpful to navigate CellProfiler: CellProfiler Workshop - YouTube.

Good luck and let us know if that works!
Pearl

Hi Pearl,

Thank you for navigating me through this. I tried adding the images folder from the example but not able to do so. Looks like it is auto disabled.

Hmm, that sounds strange. Perhaps there’s a file permissions error with the software.

  • What makes you say that loading images appears to be auto disabled? Is there an error message that you see? If so, a screenshot would be helpful.

  • What platform are you working on? (Mac / PC, operating system version).

  • Can you import any other images into CellProfiler or is it specific to the ExampleSpeckles images?

  • If you move the images to a different location (such as into your documents folder) and then try to import into CellProfiler, does that make a difference?

I think you are right. There might be file permission error issue.

  • I am not able to import any of the images from the example pipelines. I tried checking with other pipelines as well.

  • I am working on a PC (Windows 10, 64-bit)

  • I am able to import other images into CellProfiler excluding the images in any of the example pipelines.

  • I moved the images to different locations but there is no change.

I did not try moving the example pipeline to the C drive. Will try doing this and let you know if it works.

Hmm, we’re going to try to dig into this a bit more.

Just to make sure, could you upload the exact copy of the pipeline that you’re working with? That’ll help us make a diagnosis.

Here you go.
ExampleSpeckles.zip (2.5 MB)

Hi @Shalini,

Unfortunately, we weren’t able to replicate this on a Mac or PC in our lab, which makes it a bit trickier to troubleshoot. Here are a couple more ideas:

  • Are you trying to load the .zip file into CellProfiler? You’ll need to unzip that folder first, then drag the folder contained within named “images” into CellProfiler
  • Could you send screenshots explaining the precise steps of what you’ve tried and any error messages? This will be crucial for us to help diagnose this problem
  • Are you certain that you’re dropping the “images” folder into the correct spot? You’ll want the folder to go within the red rectangle highlighted here:

Best,
Pearl

Hello Pearl,

The very basic mistake that I did was not unzipping the folder. It should automatically unzip when you double click on the .zip file and ask for a location. But here it was not the case. And I was assuming that I was transferring images from an unzipped folder.
I unzipped it properly and tried again, it worked. :smiley:

Many thanks for your help!