Error in loading ome.tiff images in QuPath

I recently updated the QuPath version to v0.2.0-m4.
I have fluorescent multi channel images from deltavision system. I use Bioformats to convert “.dv” image files to "ome.tiff’ and then try to upload into QuPath and I got this error “java.lang.illegalStateException: Weights must be non-negative”.
With the previous version, I was able to use the ome.tiff files.
Thanks in advance for the help.

Hard to say much without an example of the ome.tiff file that doesn’t work. There are plenty of ome.tiffs that work, so it isn’t the file format itself. The full error log might help Pete diagnose this as well.

When I try to drag and drop an image, it gives the following error and error log.


ErrorLog.pdf (80.0 KB)

Just to make sure, this is dragging and dropping it into a project, not a blank QuPath window, right?

Also, it looks like you have an extensions folder with BioFormats, which you shouldn’t have for any 0.2.0 version. In some cases having that will break things that would otherwise work.

Have you tried adding your images without the BioFormats extension, and without using drag and drop (adding them using the add images dialog in the project tab which was the normal method prior to M3)?

I’m afraid this is a new bug that I learned about recently. This fix is here and will be in the next milestone release:

The problem isn’t directly with OME-TIFF support; it affects all large images that aren’t tiled/pyramidal (where ‘large’ depends on the number of pixels/bit-depth/channels).

1 Like

One more thing to add to the test list! :slight_smile:

I guess that, temporarily then, a work around would be to generate a ome.tiff that is tiled through BioFormats?

Tiled and pyramidal.

1 Like

Right! I’ll blame that one on waking up.

Thanks @Research_Associate and @petebankhead for your replies.
I am a new user, can you explain how can I use this fix so that I can analyze images?

The easiest way is to wait for the next milestone release (hopefully in the next 1-2 weeks). In the meantime you could try an older version of QuPath that doesn’t have the problem.

Or if you have a lot of time and are unable to go back to an earlier version, you could try something like what is mentioned here:

I have no idea if that exact script will work for you, but it might get you started as many of the useful links are already provided. Possibly one of the BioFormats people could help more if you run into trouble.

*this would likely require some trial and error, and frustration. The easiest solution would be to use an earlier version if possible.

Thanks @petebankhead and @Research_Associate. I will try your suggestions and also wait for new release.

Returning to this… do you need to convert at all? QuPath also uses Bio-Formats, so there should be no need to convert to OME-TIFF.

Or, if you do convert to OME-TIFF, you should be able to do it by opening the image in one of the recent QuPath milestone releases (v0.2.0-m3 if you’ve trouble with m4) and using File → Export region → OME TIFF - which should automatically save as a tiled pyramid if needed.


I tried to upload “.dv” files containing multichannel panel fluorescence images and I got error but with “ome.tiff” it was working. I will check again with earlier versions if I can upload .dv images.

If they are multi-part files, definitely make sure you open them in a project, not just as a solo image.