Error in loading Matlab libraries

cellprofiler

#1

I have compiled CPCluster with no error messages but was not able to run it:

./CPCluster: error while loading shared libraries: libmwmclmcrrt.so.7.4: cannot open shared object file: No such file or directory

This appears to be the warning of Step 3 of your Directions to compile CPCluster.m.

I later tried to compile using the -z option where is the directories where the libraries are stored. I also tried copying the library file into the CPCluster directory. However, I see the same error message.

Could you let me know what I am missing?

In addition, for Step 6, do you mean copying the contents of V73 into MCR such that the contents of MCR is the X11 directory and not the V74 directory (which contained the X11 directory)?

Steven.


#2

I edited the CPCluster.command file and specified /MCR/X11 as the directory and it appears to be working now.


#3

Hi Steven,

The X11 folder should stay in the MCR folder, so it should be Cellprofiler/MCR/v73/X11 or CellProfiler/MCR/v74/X11, depending on the version which was downloaded. Was this the issue causing your problem?

Mike