Error importing .am files - bio formats

Hi there,

I am trying to import an avizo file which is a .am file. In the online description of bio Formats it says that .am files are supported but when I try to do the import i get an error message:

loci.formats.FormatException: Syntax Error:11:14: Invalid key
	at loci.formats.tools.AmiraParameters.syntaxError(AmiraParameters.java:152)
	at loci.formats.tools.AmiraParameters.readMap(AmiraParameters.java:383)
	at loci.formats.tools.AmiraParameters.readMap(AmiraParameters.java:387)
	at loci.formats.tools.AmiraParameters.readMap(AmiraParameters.java:387)
	at loci.formats.tools.AmiraParameters.readTopLevel(AmiraParameters.java:196)
	at loci.formats.tools.AmiraParameters.readFile(AmiraParameters.java:111)
	at loci.formats.tools.AmiraParameters.<init>(AmiraParameters.java:74)
	at loci.formats.in.AmiraReader.initFile(AmiraReader.java:142)
	at loci.formats.FormatReader.setId(FormatReader.java:1389)
	at loci.plugins.in.ImportProcess.initializeFile(ImportProcess.java:499)
	at loci.plugins.in.ImportProcess.execute(ImportProcess.java:142)
	at loci.plugins.in.Importer.showDialogs(Importer.java:140)
	at loci.plugins.in.Importer.run(Importer.java:76)
	at loci.plugins.LociImporter.run(LociImporter.java:78)
	at ij.IJ.runUserPlugIn(IJ.java:230)
	at ij.IJ.runPlugIn(IJ.java:193)
	at ij.Executer.runCommand(Executer.java:137)
	at ij.Executer.run(Executer.java:66)
	at java.lang.Thread.run(Thread.java:748)

Does anyone know why this might be?

thanks!

B

It looks like Bio-Formats has encountered some metadata which it has failed to parse, in this case likely an empty key in the metadata table. If you are able to upload the sample for testing to https://www.openmicroscopy.org/qa2/qa/upload/ then I can try to help debug the problem further.

Hi,

The file is larger than 2GB so I cant upload it via that link. Any idea how I would find the missing key in the metadata table?

thanks,

B

If you PM me with your name and email address I can arrange for ftp access for larger file transfer. This will likely require a fix in the Bio-Formats reader in order to resolve it, I will try and open a fix later today for testing.

As a follow up to this I have opened a PR for testing at https://github.com/ome/bioformats/pull/3435