Error: Failure in analysis startup CellProfiler 3.1.8

I am trying to run CellProfiler 3.1.8 on MacOS High Sierra 10.13.6.

I get the error “Failure in analysis startup” when I try to run an analysis. I have been troubleshooting based on previous posts with this error and have not gotten any closer to a solution. I have even tried analysis with the “Example Speckles” sample pipeline and images directly from the CellProfiler website (attached) and I’m still having the issue.

Any assistance would be appreciated.

Edit: to clarify, I have run this analysis or similar ones on Cellprofiler 3.1.8 for Windows 7 and Windows 10 without issue. Since the sample pipeline doesn’t work, I am assuming it is an issue with the software and not the pipeline.

I have tried uninstalling and reinstalling, and I have also installed 3.1.5 and tried to use that, to no avail. The pipeline I was attempting to run was a speckle counting one similar to the one attached.

ExampleSpeckles.zip (2.5 MB)

Anyone have thoughts on this?

I have a thought, but it’s not encouraging. I get the same problem in OSX 10.13.6, using either 3.1.8 or 3.1.5. It does not help to re-install CellProfiler or run earlier versions of Java. Maybe it works on newer versions of OSX? I do not want to upgrade this computer so other people will have to weigh in on that.