Error: "Could not load file as an image"

Hi, I am a new user of CellProfiler. When I download the examples from the web, everything works fine. However, when I try using the same pipelines as templates with my images I get always the same errors: “Could not load file as an image”, or: “Test mode disabled because there are no image sets”. Pipeline and images files are in the same folder. My images are two-color composite .tif pictures from cells immunostained with DAPI (blue) and a specific Alexa fluor Ab (green).

I tried using several pipelines from your web (ColorToGray, Example%positive…) with my images and always get the same message. I´ve been reading some other posts and I guess there is a problem with NamesAndTypes but I do not know how to solve it. In the manual only says to load ones images.

Could someone give me a step by step walkthrough on this? Thanks a lot!
Javier



I am also receiving this same error message “[Errno 22] Could not load file as an image” and “Test mode disabled because there are no image sets”, though I suspect for different reasons. My files are between 50MB (jpg) and 700MB (tif) and will not load in CellProfiler, but my tiled versions (~2MB/each) seem to run fine. From what I had read, I was under the impression that CellProfiler does not have a hard limit on file size and that my hardware was a much more realistic limitation. I have a 64-bit processor with 12GB of RAM; How much more memory would I realistically need for these images? If at all possible, I would prefer not to tile my images as I am unsure of how the borders would affect my IdentifyObjects modules and overall analysis.

As Javier mentioned, other posts suggest a problem with NamesAndTypes. If this is the case, I also do not know how to solve it.

Any further information regarding these types of errors would greatly be appreciated.
Thanks,
Chris

Javier44: Would you mind posting the pipeline/project file that goes along with the posted image and produces the error?

Chris: Going form 50-700MB down to 2MB just by tiled is a pretty drastic reduction in file size. Are you downsampling your images to tile them? And how big (in pixel dimensions) are the two types of images?
-Mark

Javier44: I created this simple pipeline (attached) and it works with your file, so I’m not sure what the issue is. This is what I did:
(1) Drag your image to the Images module settings area. (Neglecting to do this could cause the error you see)
(2) In NamesAndTypes, change Grayscale Image to Color Image, since this is a simple RGB tiff.
(3) Create a simple pipeline. here we need ColorToGray, but I see that you are using that too. Ensure that your downstream modules are using the created grayscale images!
This simple pipeline completes using the current release version of CP.

If you or Chris (@cbrueckn) find what was wrong, let us know so we can try to make it more apparent how to avoid it!
David
DLproj.cppipe (7.17 KB)