Error 3D results (anisotropy) Fiji


I am trying to do a 3D MIL/anisotropy analysis using Fiji, where I would like to get the 3D results. However the program gives an error (see picture below).

Does anybody know what may be causing the problem? And how it can be solved?

Many thanks!


To use BoneJ with Fiji, you need to use the legacy Java 6 version of Fiji. BoneJ does not work with the current (Java 8) download of Fiji, due to changes in Java 3D and the 3D Viewer.

See this page for instructions on how to download the latest Java-6-compatible version of Fiji, into which you can install BoneJ.

Thank you for your quick response. I downloaded Java 6. However, still the same errors appear if I want the 3D results of the anisotropy calculation.
Remarkably, other parameters like thickness, whereby BoneJ is used, do work.
Could something else be the problem?

It is highly unlikely. The error message you posted indicates a skew between BoneJ’s expectation of Java 3D version 1.5, and the latest Fiji’s use of Java 3D version 1.6.

Did you download the Life-Line version of Fiji and upgrade that? Without the Java-8 update site enabled? As described on the page I linked above?

1 Like