Ellipsoid factor problem getting values -1 to +1



Hi there,
I am running ellipsoid factor and getting values either around 4 or 200, never between -1 and +1.
I am using the ROI on my stacks (trabecular bone), and click:
plugins - ellipsoid factor-
then afterward, analyze - histogram.

Is there something I’m doing wrong?
Thank you!



Thanks for your interest in Ellipsoid Factor!

The first possible explanation that comes to my mind is that you are running the histogram on the wrong output image of the Ellipsoid Factor plugin. You should select the image with the title starting with “EF-…” before running analyze-histogram. Does that help?

If not, I’d be interested in a minimal example that can recreate your issue: I would need to know which parameters you are running ellipsoid factor with and an (as small as possible) stack of binary images (representing the trabecular bone) if that is possible? This would help narrow the problem down.

Do not hesitate to ask further questions or let me know if you need further clarifications! I hope this helps!



Thanks, it worked!

I also have the issue in some cases where I can’t get the two boxes to pop up (like the EF test stopped). Do you know why that can be happening?

I’m rerunning all of them now so I’ll see if they’re particularly large files.

Thanks again for the quick reply.


I’m glad it worked!

Apologies - I don’t understand what you mean by “the two boxes”? Could you clarify that?



By “two boxes,” I meant the output images.

But now I’m not sure if I should be checking the box next to
when first running EF, or not. In a previous post, Dr. Doube said to check that box, but I didn’t see it, and did all my analyses without doing that. When I re-did them with checking it, I get slightly different values.

Thanks for all your help. I’m excited to correlate it with the SMI’s.
I can’t get plateness to run anymore so I guess that feature is not longer working in BoneJ.



Off the top of my head, I can’t think of any specific reason why sometimes some output images would not pop up, assuming you are doing the same thing every time. Does your Log window report anything? Again, a minimal working example demonstrating your issue would be helpful to narrow any issues down.

I’m guessing you are referring to this post (?) and you are talking about the checking Stack Histogram checkbox. Is that right?

If so, I would recommend you do check the Stack Histogram checkbox - it means that you will get a histogram of EF values for the entire (3D) stack of images, and not just the (2D) image currently on display. Does that help?

My pleasure - I am interested to see how you get on with EF (I am currently developing the BoneJ2 version of EF, so any feedback/suggestions on what works and what doesn’t is very welcome). Based on Figs 3 and 4 of this paper I would not expect much correlation between EF and SMI, but rather some correlation between SMI and BV/TV… I am happy to be proven wrong, of course!

I’ve never used plateness, but this entry on the BoneJ homepage suggests it has been replaced by EF.

Hope this helps and let us know if not!



@seagulldvm in response to your other questions:

I’m still awaiting whether I check histogram after unchecking pixel. I saw in a post to someone else you said to do that. Also, is platemess not working anymore on Bonesj?

I’m not clear what you mean by “check histogram after unchecking pixel” - in what dialog box are you working when you do that?

Plateness has been deprecated and replaced by Ellipsoid Factor, meaning that Plateness is not working any more.

  1. How many sampling increments are ideal (using the default of 100 takes a long time, but I’ll do it if that’s ideal)

It depends on your images, and I think you may be referring to the number of vectors ,which defaults to 100. It is worth doing a sensitivity analysis to see how varying sampling increment and number of vectors changes your results.

  1. On the one I tried, I get a mean of 255 and a St. deviation of 0, when I analyze the histogram, then analyze - set measurements, and then go to image-stacks-statistics.

I think Ale handled this earlier - you have to analyse the histogram of the EF image, not the binary input image.

  1. The program seems finicky if I put in my own threshold (seems to prefer if I just go to process - make binary) and also if I set the scale.

Setting a scale shouldn’t affect the EF result, because it’s a unitless ratio, unless you set the scale to have anisotropic pixel spacing (i.e. pixel width, height and depth are not all equal) when pixels are actually isotropic. You do need to start with a binary input image. With the Image > Adjust > Threshold command, select the threshold then hit apply.


Hi there, when I go
analyze --> histogram, the box that comes up:
X min
X max
Y max.
I know x should be 01 and Y should be +1, but I’m not sure what to put for X min and X max? Are they both -1?

Thank you.


Screenshot from 2018-05-25 20-15-14Screenshot from 2018-05-25 20-15-50


Sometimes Ellipsoid factor calculation stops and won’t continue, so I can’t get the values. I got it to work for 2/3 of my dataset but I have about 8 samples I can’t get it to finish. It says “ellipsoid at (a point) is invalid, nullifying after x iterations”. I’m not sure what to do. Thank you.



The log message “ellipsoid at (a point) is invalid, nullifying after x iterations” is completely normal - Explained simply, EF tries to find ellipsoids that fit within the trabeculae, and when it finds that one of the candidate ellipsoids is invalid (e.g. when a large part of it is outside the input image) then it writes that log message and forgets about that candidate ellipsoid.

To help you further, we would need to know in more detail what you mean by “I can’t get it to finish”. Could you give more details, please?

Thanks and best,


Sorry, it just pauses, and never resumes.
You had mentioned I could send you a dataset, is there any way I could do that? Thanks!



I am happy to try running EF on one of your samples if you provide me with the binary image (via a dropbox/google drive/… link shared here or via email) to see whether if I can reproduce your problem on a different computer. If you want to do so, please also provide me with the exact parameters that you are running EF with, as well as the versions of ImageJ/Fiji and BoneJ you are using.

It would surprise me though if I can reproduce your problem, seeing as it does seem to work for some of your samples? Is there an obvious difference between the samples that do and those that do not work?



@seagulldvm please send us some images that show the problem - they’re very helpful for debugging. It’s also possible that your images are ill-suited for the analysis: if all the ellipsoids grow until they get nullified (i.e. they don’t hit a boundary inside the stack), then the analysis will complete without giving you a result. Please paste here the rest of the output from the log window (@alessandrofelder I forget - will @seagulldvm need to turn on debug logging in the ImageJ settings?)


Thanks, @mdoube - I am in e-mail contact with @seagulldvm to see whether we find a solution (one of us will post the outcome here, I expect) - I’ve never used debug logging, but it seems like a good idea: @seagulldvm if you could follow these instructions to have additional messages displayed in the Log window and post the entire log output here, that could be useful - thanks!