Edge detection side

Dear all,

When use Morph edge detection function, sometime it will check the side I am not interested. And I have tried " reverse axis", but it not seemed not work. Do you know how to figure it out?

Thanks in advance.

Sample image and/or macro code

  • Upload an original image file here directly or share via a link to a file-sharing site (such as Dropbox).
  • Share a minimal working example of your macro code.

(If this is your first post, you may not be able to attach images, in which case make a post with a link or a first post without the image attachment and a second one with)

Background

  • What is the image about? Provide some background and/or a description of the image. Try to avoid field-specific “jargon”.

Analysis goals

  • What information are you interested in getting from this image?

Challenges

  • What stops you from proceeding?
  • What have you tried already?
  • Have you found any related forum topics? If so, cross-link them.
  • What software packages and/or plugins have you tried?
    3.bmp (4.2 MB)

Hi lei_li,

To me it is not immediately clear what went wrong.

It helps to turn on the visualization of the coordinate system axis. To do that just press “A” in the main window.
The “Edge Detection” process will always look for edges coming down from the z-axis, so you can already visually verify whether your sample is facing the right way before running the edge detection.

Another thing to pay attention to is to use the right stack. From your screenshot it looks like that’s the one in white color. Now when you reverse the axis, the main stack will not change, but instead overwrite the work stack with the reversed-axis-stack. By default the “Work” checkbox should then be checked, so that this stack is used when you run the edge detection. Maybe you unchecked the “Work” checkbox here and run edge detection on the main stack?

Cheers,
Soeren

Hi soeren,

Thanks for your reply. It is totally right, I just realised that I not checked the z-axis before turn “work” to “main”. :rofl: