Edf files and ImageJ

I am having edf files that are collected in a synchrotron by SAXS.

I have downloaded imageJ and all the required plugins, but i couldn’t open the images properly.

Attached how the image is opened.

Can anyone help me in opening them.

Thanks and Best Regards

@a.el-husseiny
Can you provide a bit more information? What version of ImageJ are you using? What plugins did you install and how? Perhaps then we can better assist you…

Additional thoughts:

Is this the plugin you tried installing? If this tool could work for you - it’s easy to install. Just download Fiji and then go to Help > Update… and click ‘Manage Update Sites’ and make sure “BIG-EPFL” is selected. Then click ‘Close’ and ‘Apply Changes’… and re-start Fiji. Then you’ll have access to these plugins…

There is also this older forum thread that might be helpful to you:

1 Like

Thanks Etarena for your kind concern and response.

What i have done exactly is the following:

I downloaded imageJ for Mac. I downloaded plugins as much as i can from the different sources and one source was from ESRF that mentioned to download 4 plugins for view slice volumes. The image is not correctly displayed as far as i understand. I don’t know how to fix this issue or what should i do.

Kindly advise

@a.el-husseiny

You need to be as specific as you can be… Please answer these questions to provide us more info:

  • What version of ImageJ are you currently running? To check… click on the status bar to report to us the version of ImageJ and Java you are running…
  • What exact files did you download and WHERE did you ‘install’ them?? Please check the link to the older forum thread I posted above… read through that.
  • Is there an error message reported? What do you mean exactly by:

???

Sorry for confusing you and kindly forgive me as i am not totally aware of this staff.

To answer you questions:

The version of imageJ is 1.51

The Java version is 1.6.0_65 [64-bit]
I pasted the files into the plugins folder and exactly in the input-output folder and in the stacks as well.

The names of the files that i have downloaded are:

Backprojector_.class
bij.jar
Depth_Coded_Stack_.class
Diffraction_PSF_3D.class
Diffusion_.class
Extended_Depth_Field.jar
FlowJ_.class
ImageJ_3D_Viewer.jar
Kalman_Stack_Filter.class
Kalman_Stack_Filter.java
Make_Ellipsoid.ijm
Make_Sphere.js
Measure_Hyperstack.ijm
Measure_Stack.ijm
MI_.class
PCA_.class
Register_ROI_MI_Edges.class
Register_ROI_MI.class
Register_ROI.class
SurfaceJ_.class
Time-Lapse_Color_Coder.ijm
Volume_Reconstructor_.class
Volume_Viewer.jar
VolumeJ_.class

Sometimes there is a message that i understand saying there is a duplicate of plugin and it is deleting this duplicate.

When i open the edf file, a warning message appears saying that " Unknown data type signedinteger"

Hoping i answered by now all of your questions.

I have done exactly the steps that are mentioned in the forum that you have referred me.

Unfortunately i got the same images.

I tried to upload the files in case you can manage to open them correctly, but they are edf files which are not the allowed format to be uploaded.

I am not sure what i am missing for having the whole picture

Kindly advise
Thanks and Best Regards

I have never used these particular plugins myself… and without access to an edf file - I cannot test. I believe @svensson is definitely the best person to help you…

Thanks Etarena for your kind response

I have sent you the files in case you can kindly open them with your software.

https://forum.image.sc/u/svensson can Please help regards this issue?
@svensson

Thanks and Best Regards

Thanks Ellen for your kind response.

Actually they are normal edf files, but i don’t know why they are not opening correctly.

I am attaching the files if you can kindly help to check if they can open normally with you.

Thanks and Best Regards

(Attachment pilatus_LPS_S28_000_0000.edf is missing)