Drag and drop is broken; LEI files are not handled appropriately

Continuing the discussion from Trying to run the Fiji:

I doubt these problems are specific to El Capitan. It is possible, but there have been drag-and-drop-related issues in the past. This issue is likely to be similar. Does drag-and-drop for other microscopy file formats work? (Specifically: formats that require the Bio-Formats plugin to open.) And what about standard formats like PNG and JPEG? Do those work with drag-and-drop?

As for the LEI behavior issues, do you have the same problems if you use File :arrow_forward: Open… to open the LEI? Or does that bring up the Bio-Formats Importer Options dialog as expected?

Some more information about this issue:

Under El Capitan and Java 8, Fiji does not accept drag-and-drop to the icon in the dock. It will accept drag-and-drop to the application window/toolbar, however .lei (Leica metadata files) are not parsed correctly, causing the first stack in a directory to be opened without prompting the user to select a stack from within that directory, and the metadata (scale etc.) is lost.

Interestingly, opening the same .lei files via File>Import>Bio-formats works as expected. So the regression appears to be in the handling of drag-and-dropped files.

There is also still an issue with the launcher, as the icon in the dock reports itself as “Java” and if it is pinned to the dock, after terminating Fiji, clicking on the icon simply starts the Java VM in a terminal window.

I don’t have any other formats to try; if you can send me a stack from another system, I’ll give it a try.

Hmm, it seems that some developer might need to bite the bullet and upgrade to El Capitan, in order to reproduce these issues.

I agree with you @bryanc that the dock reporting “Java” is almost certainly a new thing with El Capitan.

Did you test drag-and-drop on any pre-El-Capitan Mac to see whether the problem occurs? The symptoms you describe sound less OS-specific to me, and more like ImageJ 1.x trying to handle the drag and drop without using Bio-Formats. (LEI files are TIFF files, and ImageJ 1.x tries to handle TIFFs on its own before resorting to Bio-Formats.)

If drag-and-drop of LEI files indeed also fails on non-El-Capitan machines, we can investigate a fix in the ImageJ Legacy layer that patches the behavior of ImageJ1.

Drag and drop works fine on my MacBook running Yosemite. I don’t have it with me to check the Java version. I’m pretty sure Fiji has been using ImageJ 2 for quite some time, so I don’t think this is an ImageJ1.x issue.

I’ll check this when I get home.

Thanks for the help!

Hmm, yeah, I just tried drag-and-drop of an LEI file on my Yosemite machine, and it works OK for me too. I tested with both Java 7 and Java 8.

Since this issue is related to the Dock, I am guessing it coincides with the fact that your dock reports “Java” instead of “Fiji.”

As a workaround for now, try dragging your LEI file onto the ImageJ status bar, instead of the dock icon.

I updated to El Capitan, only to find out that Fiji does not work anymore. After downloading the Java JDK I could open Fiji again, but not open any of the confocal files by drag and drop onto the Fiji Symbol or by choosing Fiji as the application to open my file. I experience the same issues you describe in terms of the icon in the dock reporting itself as Jaca. We are using the Olympus System, hence Bryan, I could send you an .oib file. That is the Olympus metadata file. It all worked without any problem when I was using Yosemite.

As a workaround, try dragging and dropping onto the main Fiji window, instead of the Dock.

I will also upgrade to El Capitan soon to troubleshoot these issues.

Thanks for your reply. Yes that also works. However, Fiji has become incredible slow under El Capitan.

Double check which Java version ImageJ is using.

Try with Java 8, Java 7 and Java 6, and let us know which one(s) work best. Then we can add this information to the FAQ.


Ultimately, we want ImageJ to work well with Java 8 on the latest OS versions. So as I said, I will try upgrading soon and investigate further.

Right now I am using Java 8. I will try the other versions and let you know

Just as update. I have reinstalled Fiji, but this time the last life-line version. With this everything is back to normal. Drag and Drop works without any trouble and so does anything else I am using with Fiji.

The reason everything is back to normal is almost certainly because the Life-Line version is using Java 6. You can check for yourself to verify. You can keep using Java 6 with the latest version of Fiji if you want—just uninstall Java 8 and Fiji will use Java 6 instead.

By the way, I upgraded to El Capitan and was able to reproduce the performance problems with Java 8, thanks to a helpful script from @Brandon_Hurr. We have diagnosed the cause, and @Wayne added a tentative workaround to the latest ImageJ daily build. You can upgrade to the daily build if you want to test it for yourself.

I’ve been limping along using the workarounds for the past few months, but the issues have all spontaneously solved themselves with the latest JDK (8 v71). So something was definitely borked in my java installation, and re-installing didn’t fix it. But the latest update has fixed everything :slightly_smiling:

I still wish I knew what happened.

Only to add my two cents, here in my research campus some users that have updated their Mac to El Capitan and they have some issues to run Fiji more over with Java 8.
Don’t remember exactly the problems they have, but for sure they have compatibility issues with El Capitan and Java8.
Downgrading Java to Java6 improves the situation.
Have a nice day,
Emanuele Martini

Very glad to hear that. :smile:

Note that this is only a stopgap solution; ImageJ2 and Fiji will fully move to Java 8 later this year. If your users continue to have difficulties with El Capitan, please report them so we can look for solutions.

Yes I know,
when it will happen again I will write here a more detailed post.
With my MAC Mavericks and Java8 everything is fine.
Thank you,