DisplayDataOnImage produces white image

Hi Guys,

 I'm having a wierd bug popup with the DisplayDataOnImage module. The viewed output of the module is fine but any modules downstream are handed a pure white image. Ive tried this with a few image types and all are loaded correctly and the output of the module itself is OK, just any modules downstream get a white image (255,255,255). Ive tried different combinations of parameters in DDOI but everything displays fine / outputs white. My MWE is LoadImages > DDOI (image number) > SaveImages.

Has anyone else seen this?

J

Hmm, I haven’t seen this. I just ran a test on Mac compiled (11710) and it looks fine for me (see attached screenshot)

Some questions:

  • Are your images single-channel grayscale? I can imagine that RGB images might cause this behavior (even though they may look grayscale). To test, in CP, when you mouse over the dispayed image in DDOI, do you only see one intensity value at the bottom of the window? or 3, RGB? If so, use ColorToGray to split the channels first.

  • What version of CP are you using? Release 11710? Compiled?
    *Mac? Windows?

If the first question doesn’t help, would you please post your pipeline and an example image?

Thanks,
David


I’ve tried both color images and grey images, both are totally white (255,*). Here is a grey image from CP’s example gallery, percentpositive.

-J


I’ve also tried to DDOI > Color2Gray > SaveImages 3x, one per channel but the input to C2G is also pure white. Attached is my pipeline.
DDOI.cp (3.49 KB)

I dragged an older MacMini over to my desk, put a fresh copy of 10.7 on it and CP 11710 and tried it again … and it worked. The other two machines I have are used for devel and most likely have changes to python (macports) etc. Could anything external to CP mess with how these images are formed? I tried uninstalling CP with AppCleaner and it picked up ~9 different items to remove then I installed a fresh copy but still had the same problem. I’m not familiar with what CP gathers externally to work though.

-J