Display of method name in auto threshold > try all

imagej

#1

Hi,

I wanted to use the auto-thresholding, and started by the “try all” method to chose the appropriate one for my data. It works fine except that the name of the methods are not displayed under each of the resulting image. I have to count the images in the “try all” montage to find the position in the list of the method I want to use, then select the 5th or 12th method in the list instead of searching for “IsoData” or “Otsu” for example. It is feasible, but not very convenient.
Does anyone know how to solve this?


#2

Hi @Passot,

The names should be displayed under each method frame, but they may be very small on your screen. Try zooming in, just hold your mouse over the image and click + on your keyboard.

On a blank image:
image


#3

Hi @Sverre,

The zoom problem was my first thought, but unfortunately, even with the zoom to 100% the names do not appear.
Here is a part of what I get on a small image:

.

But I just got the illumination while writing this answer: the problem was that my background color was set to white, and the names are written in white too, so I couldn’t see them. I set my background color to black (double-click on the pipet tool, if anyone gets the same trouble someday), and now it works as expected:

Thanks for your answer @Sverre, seeing the black background on your screenshot helped me realise what the problem was! :grinning:


#4

Huh, I never would have guessed. Glad you figured it out :slight_smile:

However, I was not able to reproduce it on my installation of Fiji. When I set the background to white, the text is black.

image

Which version of ImageJ/Fiji are you using? Did you change something other than background color?

(Click your imagej taskbar to see the version)

image


#5

Here is my Fiji version:
image
I just updated it yesterday before my first post, but I had the same problem 3 weeks ago with a previous version. I usually update my Fiji at least once a month, so it cannot have been an old version. My computer is running on win7 SP1.

When I had the problem, my background color was set to white and my foreground color to black. To get it to work, I just inverted the background and foreground color.
I had also tried to change the parameters of the auto-treshold to detect dark or light objects, but it made no difference (which is not surprising).

It does seem like something is wrong in my FIJI if you cannot reproduce the problem, but for now I will do with the change of color background. If I find anything else that affects it, I will post an answer here.