Disable the binay or image source download in omero insight/web interface

Hi @OMETeam

I already posted this question, Still, this feature is needed some more clarifications.

To disable the download source option in the Omero interface for Read-Only Group user is still active.
The command I tried is

omero config set -- omero.policy.binary_access -read,+write,+image,-plate
And also tried this
omero config set -- omero.policy.binary_access -read,-write,-image,-plate
But still I’m able to download the source files.
Want to disable or remove the third icon in the below image url.
URL https://docs.openmicroscopy.org/omero/5.6.2/_images/downloadRestriction.png


The second (right) of the menus in your screenshot doesn’t include any of the options for exporting binary data. Those options (TIFF, PNG etc) are the ‘rendered’ images, the same as are shown in the viewers. These are essentially the same as taking a screenshot, so disabling these won’t achieve much.
Hope that makes sense?


Hi, Thanks @will-moore

I wants to disable the download source file options Screen shot attached.
The first option allow read only user to download the source file.I wants to disable the first one (Download).

Are you trying this on OMERO 5.2? (looking at previous discussion Omero Server Data migration)

If so, then I’m afraid this feature may not be supported.
Or, it may just be a bug in the webclient, so that the menu is not disabled, even though the server would still prevent download?
If that’s the case, and it’s working on the server, then that might be sufficient for you? But otherwise I’m afraid you’ll need to update to OMERO 5.6 since we don’t support 5.2 now.


Hi, Thanks @will-moore for reply.

Forget about the omero 5.2 version, I am tried with the omero 5.6 only.
omero config set -- omero.policy.binary_access -read,+write,+image,-plate its worked with OME-Tiff file only. Not with Download Source (.svg) files.

Can i restrict based on the group ? To disable the download source option in the Omero interface for Read-Only Group user.



You certainly need -image if you want to disable download of single images.
You also need to ensure that you restart the server after setting config:

$ omero config set -- omero.policy.binary_access -read,-write,-image,-plate
$ omero admin restart

Just tested myself. The screenshots show before and after setting the config and restarting.
The OME-TIFF export isn’t affected by this setting. You’re probably seeing it disabled before you set this config (because it’s a big (tiled) image?).

Screenshot 2020-10-22 at 09.50.08 Screenshot 2020-10-22 at 09.54.00



Hi @will-moore

Thanks for the reply, its works fine with the Download source ie what you shared in the image attachment, but the user not able to download the attachment in the Image folders.
Image attached.
Screenshot_2020-11-20 Webclient

Attachment show the file but greyed out not able to download.

I want to restrict the Read-Only (rwr—) Group user not to download the Image source and download the attachment file in the folder for the workout.


Hi @vsnlme108,

Sorry, that level of granularity is currently not possible. There would need to be a separate option added, for example, attachment. I’ve filed an issue to capture the request: