DiameterJ does not work - Segmentation is black on white

Hello.

Since yesterday I started experiencing problems with ImageJ - see Macro Error when following the tutorial "Learn DiameterJ"

I have unistall and install again ImageJ around 4 times during the day but I cannot solve the issue. Eventually the problem is more extended.

Right now I am using DiameterJ to segment a picture and instead of having the usual binary images with white fibers on black background I get the opposite (black fibers on white background). While processing the segmentation there are several messages of error in the Log window. I also called a colleague of mine and she told me that the segmentation does not work for her either.

Can somebody explain what is going on? We both need to use ImageJ for our research and we cannot process any images.

Thank you for the help!

I am not familiar with the plugin, but in the off chance it helps, that sounds like something from a discussion yesterday concerning the “Make Binary” command:

Also, without actually listing/including the error text, it will be hard for anyone who knows the plugin to help.

In the Log, while analyzing, a message like this appears and disappears:
MinError(I): NaN, not converging. Try ‘Ignore black/white’ options

1 Like

and the segmentation appears like this

image

1 Like

the thing that I don´t understand is what has changed. I have been using ImageJ and DiameterJ in the last three weeks without any problem!

Have you tried processing the exact same images? Not the same type of images, but the exact same images you were processing before.

Yes. I have been following the training for learning DiameterJ and right now I am using the images that are uploaded in the training and I have been analysing in the previous training sessions. It doesn´t work.It doens´t work neither the segmentation nor the analysis of segmented images (given on the training page already segmented). Here is the link to the training: https://sites.google.com/site/diameterj/home

Ah, I see. Well, hopefully someone familiar with diameterJ will be along shortly. There should be enough information now for someone to help, but again, I have never used it.

It also looks like you aren’t the only one running into this error with that plugin.

Maybe this post will be useful, but I would recommend searching the forum. There seem to be a few posts about this.

I have seen the conversation while we were talking, thank you for reporting it here too. I followed their steps (using Fiji only now) and it seems working.
Now I am back to the beginning that the plugin works and at the end I get this message

“No window with the title “temp.csv” found”
image
I have results but I don´t understand if this error means that there is some problem in analyzing or the results are reliable.

Maybe @casimur or @NHotaling can help?

1 Like

Coule you please tell me which version of ImageJ and DiameterJ you use? I tried many times, “DiameterJ segement” reports me successfully segemented, but no results in appointed folder.

Thanks!

Hi. I have the same problem. I’ve tried to run the program in different computers changing the SO (W10 and LinuxMint) without solution. There’s any chance that you finally solved and could you tell how?

Did you try all of the steps in the post linked above?

Yes, actually I had the same problem of that post and I solved it by applying that procedure. I’m going to try now with DiameterJ 1-017 to see if this can help me. I’ll update if I’m lucky.

So there it is, using v.1-017 I could do the analysis without problems. I’m not sure if this will work for everyone, but you can try.