DefineGrid Error

When I ran my pipeline containing the DefineGrid module under the test mode, everything worked nicely, but when I tried to run the pipeline to analyze images, the following error message popped up.

Error while processing DefineGrid:
(Worker) AttributeError: 'module' object has no attribute 'figure'

Traceback (most recent call last):
  File "cellprofiler\pipeline.pyc", line 1929, in run_image_set
  File "cellprofiler\modules\definegrid.pyc", line 403, in run
AttributeError: 'module' object has no attribute 'figure'

The pipeline would then continue to run forever without exporting any files and the program would hang when I tried to ‘stop processing’.

I did notice that when I unchecked the box for ‘Retain an image of the grid’, the problem went away.

To recreate, make a test pipeline with IdentifyPrimaryObjects and then DefineGrid, with all default settings except checking the box for ‘Retain an image of the grid’.

I’m running CellProfiler 2.1.0 (rev 0c7fb94) on Windows 7 64-bit.

Hi,

I tried running the yeast patch identification pipeline from our examples page (which contains a IdentifyPrimaryObjects and DefineGrid modules) and it seemed to work fine in both test and analysis modes. So I wonder if it’s a problem with the particular image set and or pipeline you’re using. Would you mind posting your pipeline and an example image set where this error occurs?

Regards,
-Mark