Deeplabcut not copying video file

I have rebuilt the PC as Win10 as Ubuntu never worked for me with Docker and I had wasted too much time.

  • NVIDIA, CUDA and Conda OK in Windows.
  • the windows GPU yaml file is fine.
  • DLC imports in iPython.

When I create a new project I don’t get any errors:

deeplabcut.create_new_project('ant_test_5','steve','C:\\Users\\DLC\\Documents\\steve_dlc\\ant1.mp4',working_directory='C:\\Users\\DLC\\Documents\\steve_dlc\\',copy_videos=True)

However it doesn’t copy any video files to the project ‘videos’ folder (for avi or mp4).
It also doesn’t list them in the config.yaml.

Likely related to the other issue, ie admin rights. This is just a windows issue, actually :/.

Ps A If I can get you back to Ubuntu ;), in general thinks are much easier, even just in anaconda as in Windows (it’s faster to analyze videos, much better Cuda support, etc)

Can you please paste the output when you run this command?

I have the same issue.

And extracted frames also not copying to labeled-data file

In Windows it’s crucial you have admin rights

Thank you for your reply! I am the Administrator and I try to choose run Anaconda Prompt (Anaconda3) as Administrator. When I run “deeplabcut.create_new_project”, it successfully creates all the files, including video file, however, deeplabcut still doesn’t copy the video into the video file, the video file is empty.

I wonder what I can try next?

Thanks,
Huasheng

Hi Steve,
I have the same issue and it wasted me a lot of time. I wonder whether you have solved the problems?

Huasheng

Can you try from the terminal, and not use Jupyter? This could be specific to how your env is created, ie open the anaconda terminal and use ipython

Awe yes, an extra disc often won’t allow writing new folders, here is the original posters (@Huasheng_Yu) resolution. Resolved deeplabcut not copying video file

Maybe next time just post solution here, vs creating a new topic, thanks!