DeepLabCut 2.1.10 compatibility with python 3.7, tensorflow 2.1, CUDA 10.1

On their github (GitHub - DeepLabCut/DeepLabCut: Official implementation of DeepLabCut: Markerless pose estimation of user-defined features with deep learning for all animals) it is mentioned that DLC is only compatible with tensorflow 1.x , which means only compatible with CUDA 10.0 or previous.

Apparently DLC is now compatible with CUDA 10.1. So I downloaded DLC into a conda environment with python 3.7, tensorflow 2.1. The install went fine without errors. However when launching python and importing deeplabcut, the following error appears:

import deeplabcut
Traceback (most recent call last):
File “”, line 1, in
File “/home/guest/anaconda3/envs/DLC-GPU/lib/python3.7/site-packages/deeplabcut/init.py”, line 22, in
TF.logging.set_verbosity(TF.logging.ERROR)
AttributeError: module ‘tensorflow’ has no attribute ‘logging’

Is this due to an incompatibility with tf 2.1 ? What tensorflow versions are compatible with which deeplabcut versions?

Answered here Is here a movement for migrating deeplabcut to tensorflow 2? - #3 by jeylau