CZI files with parentheses in name

fiji
imagej
bioformats

#1

This is perhaps a BioFormats issue and not a Fiji issue. Regardless, maybe someone can help.

Take two CZI files, name them:

image.czi
image (B).czi

Drag the second one into Fiji and the first file opens. It feels like something to do with the way CZI series are handled as if only the second file is present, it opens just fine. All options are unchecked in the CZI section of bioformats and the only box checked in the BioFormats importer window is Autoscale.

If you want to try it, some examples files are here:
czi_files.zip (4.8 MB)

Does anyone have an idea how to prevent this behaviour in Fiji?