Crop module error



Hi, I get this error using the latest 3.0.0 release if I try to resize the rectangular selection when cropping, but it goes ahead without an error if I leave it as it is (a square):
‘Error while processing Crop:
slice indices must be integers or None or have an index method’

Can you advise?


Thanks for reporting this!

Do you mind posting the pipeline and whatever images are needed to run it? That would help us diagnose.


Hi Anne,

Here is the pipeline and one example image.

I’ve exported one Tiff, I normally use the images straight from the lif file by extracting the metadata, so you’ll need to tweak that (the entire lif file is way to big to share online).
Thanks a mill,



I’ve verified your issue, it’s a bug in the software; I’ve filed it here and hopefully we can get a fix for it soon. Thanks, and sorry!


Hi Beth,
Could you please alert me when this bug is fixed so I can download the latest version and do my analysis?
Thanks :slight_smile:


Hi Kinga,
The link I posted in my last reply will be the most up-to-date place to get updates on the fix.

It seems like this a 3.0 specific bug, so you could also work in 2.2.0 until our team is able to fix it; if you don’t have it you can find it on our previous releases page.

Sorry for the inconvenience!


Hi Beth,

There is another bug on the previous release when all objects are excluded due to ‘touching the border’ - that’s why I couldn’t wait to get the new release but now I cannot crop - I could do it in Fiji, but it’s a bit tedious and it struggles with so many images.
I’ll be patient and wait it out as I love Cell Profiler :smiley:


Hi Beth,

I’m running into a similar problem with 3.0.0 where when I crop an image using Fiji and feed it into CellProfiler, it states " Error while processing IdentifySecondaryObjects: (Worker) error: (1<=kx && kx<=5) failed for 5th keyword kx: regrid_smth:kx=0"

I’ve tried both a rectangular crop and a square crop. Both fail with the same error. Do you have any ideas as to why this is happening?