I have a recurrent error on CP (Windows PC Binary Version 32-bit platform) with the following error messages:
*error in cellprofiler>analyzeImagesButton_Callback at 8955
*error in cellprofiler>gui_mainfcn at 10644
*error in cellprofiler at 63
*error using cellprofiler(‘AnalyzeIageButton_Callback’,gcbo,],guidata(gcbo)) Index exceeds matrix dimensions
*error while evaluating uicontrol Callback

I can’t figure out why these errors appear. For the main pipeline I am using, there is no problem. But when I tried to segment more objects, I usually have this error. I thought first it was a memory problem, so I changed preferences to not display windows. I also added a speedupcellprofiler module to clear the memory after each cycle.

Any help appreciated!



Hello Laurent,
Please send me your pipelines and a small set (2-3 images) in a compressed file and I can take a look. My email address is . It would be helpful to see your main pipeline (when you are not seeing the problem) and the 2nd pipeline where you try to segment the objects.



Are you using the Relate module? I have seen a crash like that being caused by a bug in that module (possibly fixed in the latest version).


Hello Thouis,

I also noticed that the relate module is involved. It has been discarded for a while but at some points, after couple of hundreds of images analyzed I still have the same error message. Could it somehow involve memory use (even though am using SpeedUp module)?



Based on the error message, I would guess it isn’t a memory issue. I expect we have a bug somewhere in our code.

Can you tell which image it is analyzing just before the crash? It would be helpful if we could try to reproduce it here. Does it happen if you just analyze the image that causes the crash (or, if it’s hard to tell which one does, a block around where you think it might be)? If so, sending Martha the pipeline and the smallest set of images you can get to cause the crash would be very useful.

Also, do you know which version of CP you are using? 4684?



I’m running the CP version 4684. I tried to isolate specific (crashing) images but it worked sometimes only. Martha asked me already to send her pipelines and images, and am waiting from her to see what she thinks.



Okay. “Sometimes” is probably enough for us to track down the cause. Martha’s out until Wednesday. If you send me the pipeline and images you sent to Martha, I might get a chance to look at the problem before she gets back.

You can send them to (unless they are more than 20MB combined, in which case, you’ll need to upload them via FTP).

Ray Jones


Hi Laurent,

I have seen this error in the Relate module too, and placing the Relate module after all Measure modules should fix this. This won’t solve your other errors, but may allow you to use the Relate module for now.



Hello Laurent,
Please let me know if you received my emails; if not, I will resend. Also, has Dave’s posting helped address your question?



BTW, I tried to reproduce the crash on my machine (Mac, running developers’ version), and wasn’t able to. I only ran through the pipeline a few times, though, because it took quite a while per attempt.