Crash upon RunImageJ CP 2.2 Win7

Continuing the discussion from CellProfiler Beta (2.2.0) has been released!:

I do run into a very similar problem when running imagej in 2.2 on Windows 7:

Traceback (most recent call last):
File “cellprofiler\gui\pipelinecontroller.pyc”, line 2826, in do_step
File “cellprofiler\pipeline.pyc”, line 2067, in run_module
File “cellprofiler\modules\run_imagej.pyc”, line 697, in run
File “cellprofiler\modules\run_imagej.pyc”, line 802, in do_imagej
File “imagej\macros.pyc”, line 104, in run_batch_macro
File “javabridge\wrappers.pyc”, line 62, in
File “javabridge\wrappers.pyc”, line 139, in __call
File “javabridge\jutil.pyc”, line 862, in call
File “javabridge\jutil.pyc”, line 829, in fn
JavaException: Macro canceled

The same pipeline works very well in CP 2.1. ImageJ plugins directory was set properly.
Could you help me to solve the issue?

Thank you!

I have the same problem. It occurs when trying to run my own ImageJ plugin (worked in CP2.1.1). I have tried with CP2.2 and CP2.4 with the same error.

CellProfiler is dropping support of all of the ImageJ modules in 2.4.0 and later releases; not sure why it’s not working for you in 2.2. Could it be a memory error similar to the one discussed in the above linked post?

I tried with a really small image (40x40 pix) and I also tried several other plugins (both .class and .jar files) with the same result, so I don’t think it is a memory error.

Why will ImageJ modules be banned from CP 2.4? I think, using ImageJ plugins is an amazing feature as it expands CP’s capabilities dramatically!

My understanding is that the integration was causing more headaches than it was solving- see discussion here.

@PRanefall If you want to upload some sample images and pipelines I can try to play with them sometime in the next few days to try to find a workaround, but if it’s truly a bug given that we’re dropping support there’s unlikely to be any fixes implemented.

Here is a simple example that works in 2.1 but not in 2.2. (You need to change None to Nothing in the RunImageJ modules for 2.1).imagejtest.zip (21.3 KB)