CPA "No Such Column" Error

image
Can anyone help me with this error I keep getting in the CPA after analyzing my images and exporting to SQLite DB.
The objects look like that:

Hi @prionbrain,

It sounds like the database is missing a column that CPA is searching for. Did you make any edits to the .properties file that you loaded? Could you also explain what you were doing when this error was triggered (did you press a particular button)?

Hi DStirling,
Thanks for replying! I didn’t make any changes to the properties file. The error comes when I double-click on any of the squares. (Which should open the full view of that image?)

Ah I see, are you running CellProfiler Analyst on the same computer that you ran the CellProfiler analysis on?

Yes:)!

I actually just modified my CellProfiler pipeline and the images and the error disappeared! :smiley: It was apparently a mistake on the type of table I created - I should do object type and not one table per object…
Of course, now I have other problems, but I’ll solve them onwards! Thanks! :smiley:

Hi David, Sorry to bother you again, but I’ve been trying to work out my CellProfiler Analyst thumbnail problem. I got to a better state but I still would like to see a full image of the selected object when I am training the machine. When I click on the thumbnail it gives me a full image and once I open the image controls it says on the bottom to click Ctrl+F or Cmd+F to find the selected object (see attached images).


However when I click Ctrl+F it just makes a ping sound and nothing happens. Do you know how I can make it show me the selected object?

image
Can anyone please help me figure out what this error in CPA means? The classifier trains OK, I got to ~75% accuracy in the confusion matrix, but when I try to score all it gives me this error. (p.s. it didn’t do that on my previous CP pipeline attempt, but there my confusion matrix wouldn’t pass 40% for some reason.)
Thanks in advance for any help!

I think this may be a bug with the RandomForest Classifier. Would you be able to try the ‘Fast Gentle Boosting’ classifier mode instead?

Thanks!
The Fast Gentle Boosting worked. It doesn’t show % accuracy on the confusion matrix though…
Also I tried the other classifier models and they gave me the same error too, so it might not be a bug only in the random classifier.

Thanks again!