CPA Error when opening SQLite-File

Hi,

first of all thank you for providing such a great and usefull tool for image processing, which is clearly superior to most other free and commercial software solutions. I wanted to process data gathered by Cell Profiler in CPA. I used the Properties File Created by CP:

*# ==== Database Info ====
db_type = sqlite
db_sqlite_file = C:\Users\TP\Desktop\Temp\Out\DefaultDB.db

==== Database Tables ====

image_table = Per_Image
object_table = Per_Object

==== Database Columns ====

Specify the database column names that contain unique IDs for images and

objects (and optionally tables).

table_id (OPTIONAL): This field lets Classifier handle multiple tables if

you merge them into one and add a table_number column as a foreign

key to your per-image and per-object tables.

image_id: must be a foreign key column between your per-image and per-object

tables

object_id: the object key column from your per-object table

image_id = ImageNumber
object_id = ObjectNumber
plate_id =
well_id =

Also specify the column names that contain X and Y coordinates for each

object within an image.

cell_x_loc = DARPP32cells_Location_Center_X
cell_y_loc = DARPP32cells_Location_Center_Y

==== Image Path and File Name Columns ====

Classifier needs to know where to find the images from your experiment.

Specify the column names from your per-image table that contain the image

paths and file names here.

Individual image files are expected to be monochromatic and represent a single

channel. However, any number of images may be combined by adding a new channel

path and filename column to the per-image table of your database and then

adding those column names here.

NOTE: These lists must have equal length!

image_path_cols = Image_PathName_DARPP32,Image_PathName_Map2a,Image_PathName_DNA
image_file_cols = Image_FileName_DARPP32,Image_FileName_Map2a,Image_FileName_DNA
*

When attempting to access images, display the table or accessing the Boxplot function, the following message appears:

*An error occurred in the program:
ImportError: DLL load failed: Unzulässiger Zugriff auf einen Speicherbereich. (==> “Invalid access on a memory area”)

Traceback (most recent call last):
File “cpa.py”, line 204, in launch_image_viewer
File “imageviewer.pyc”, line 216, in init
File “imageviewer.pyc”, line 542, in OnOpenImage
File “datamodel.pyc”, line 148, in GetAllImageKeys
File “datamodel.pyc”, line 81, in if_empty_populate
File “datamodel.pyc”, line 49, in PopulateModel
File “dbconnect.pyc”, line 534, in GetAllImageKeys
File “dbconnect.pyc”, line 47, in fn
File “dbconnect.pyc”, line 404, in execute
File “dbconnect.pyc”, line 272, in connect
File "sqlite3_init
.pyc", line 24, in
File “sqlite3\dbapi2.pyc”, line 27, in
File “_sqlite3.pyc”, line 12, in
File “_sqlite3.pyc”, line 10, in __load*

Do you have an idea what I have done wrong? I also tried with the sample-dataset, which worked once, but then the error appeared, and even due repeated installation attempts, I could not fix the problem.

Kind regards and thank you very much in advance for any hint,

Tobias Piroth

Hi Tobias,

So sorry for the neglect. There was a period where I wasn’t getting alerts to posts on this forum. Were you able to figure this out?

-Adam