CP will not open, it only shows a black screen


This is the only thing I see once I try to open CP 3.1.9. After this screen is there for about 40 seconds, this following screen appears and immediately closes the program.

I have installed Java 64-bit, as well as have the utc checked in, and it will still not open.

Hi @Jenny_Penaloza,

Would you be able to confirm which version of Java you’ve installed?

I have the up-to-date Java 8 64-bit

That’s good, if you open up System Environment Variables are you able to find CP_JAVA_HOME? If so, could you check that it’s properly pointed to your java installation directory.

Yes it is set up correctly

Okay, do you also have JAVA_HOME set on that same screen?

Furthermore, could you open command prompt and post the result when you type “java -version”?

Yes JAVA_HOME is set on the same screen
and this is what i get when I type java-version

Okay, that does appear to be some sort of java installation issue. Were the environment variables definitely pointing to the correct folder? If so, it might be worth trying to reinstall java, ‘java -version’ should produce something like the following if it’s been installed properly:

java

I got the prompt now for java, but CP still does not open.

That’s a positive step, could you show us what your system environment variables look like?

This is also assuming that the error is the same as before.

It looks like CP_JAVA_HOME should be pointed to C:\Program Files (x86)\CellProfiler\java rather than the main folder. Could you see if it works if you correct that.

I have changed the CP_JAVA_HOME to C:\Program Files (x86)\CellProfiler\java but it did not open CP, it still shows the black screen.

Now that java is installed correctly, I’d suggest that you try reinstalling CellProfiler from scratch to see if that fixes it.

It still produces the same black screen.

Okay, could you send a new screenshot of the current error message?

Just to cover all the bases and make sure everything is indeed setup properly, it might also be worth sending an image of the Environment Variables screen as you did before. I trust “java -version” also still works?

I believe it works now, since it opened CP. I disabled UTC-8 and then re-installed CP again, and it took about a minute for it to develop the following code and open CP.

I meant that I disabled UTF-8.

1 Like

Good to know, well done!

1 Like

Thank you so much for your help.

1 Like