CP “Failed to load CreateBatchFiles” bug

No way to run CP 2.1.1 under Windows 7 x64 on HP Z800 workstation (see snapshot attached).
Also tried CP 2.1.2 last trunk build, it gives the same error.

Hi,
When does this occur? Upon launch of CP? Or when you click Analyze? Did this just start occurring?

If Analyze, can you show us a screenshot of your settings, or attach the pipeline? It’s possible that there are non-US characters in the CreateBatchFiles settings that we haven’t decoded properly.

Thanks,
David

[EDIT] Github bug filed here: github.com/CellProfiler/CellPro … ssues/1332

CreateBatchFiles is supposed to work with any unicode output folder name, but it seems like there is a bug related to yours. Could you email us the name of your output folder? Also, a work-around would be to create a folder for your default output folder that uses only ASCII, for instance, “C:\output”.

Hi,

It happens upon launch of CP. This user can run CP 2.0 on his machine but was never able to run CP 2.1.1 nor CP 2.1.2, which I now use to write pipelines.

Cheers,
Sébastien

The last trunk build solved it. Thanks!

Good, thanks for writing back!
David