CP 3.0.0rc1 not starting up in Mac

cellprofiler

#21

Hello,
I have been having the same issue… Trying to run on a macOS and this is the error cmd throws at me:

No handlers could be found for logger “javabridge.locate”
Could not find Java JRE compatible with x86_64 architecture
Could not find Java JRE compatible with x86_64 architecture
Traceback (most recent call last):
File “javabridge/jutil.py”, line 273, in start_thread
File “javabridge/jutil.py”, line 125, in _find_mac_lib
UnboundLocalError: local variable ‘cmd’ referenced before assignment
Failed to create Java VM
Traceback (most recent call last):
File “CellProfiler.py”, line 8, in
File “cellprofiler/main.py”, line 152, in main
File “cellprofiler/gui/app.py”, line 53, in init
File “cellprofiler/utilities/cpjvm.py”, line 102, in cp_start_vm
File “javabridge/jutil.py”, line 314, in start_vm
RuntimeError: Failed to start Java VM
[96065] Failed to execute script CellProfiler

I installed home-brew and ran the python install and I have java 8 as well as the development kit. Please let me know if something can be done about this.

Thanks!


#22

It’s helped me to open terminal and add the environmental variable JAVA_HOME to where your base java folder is. Like,

export JAVA_HOME=/System/Frameworks/JavaVM/jre1.8.0_162/home

inside of this folder is a folder called bin which contains the java binary. To find yours, you can try to,

ls -lah /usr/bin/java

on terminal and it would reply with a path to the real java binary.

CP adheres to this and it’s allowed me to switch which java I want CP to use. This solves the javabridge error above for me.

J


#23

Hi,

I am really eager to see what is new in CP 3.0, but after installing the Mac version in my computer, CP 3.0 won’t start.

It appears on the dock, it jumps a couple of times and it closes again.

Any input?

Thanks!


#24

Hi Carlos,

It seems like you encountered similar issue of the first poster of this thread. Please follow along the discussion, and check if you have a correct version of Java (which should be 8, not 9).

Bests,


#25

Actually the error is similar. But even making all the changes I am still not able to use the CP.


#26

Can you post the output of java version ? Have you tried setting JAVA_HOME as in the post above? Thanks.


#27

Already tried! But the CP just appears the icon and disappears again. Version 2.0 works, but I need 3

kkk
tk


#28

Hello,

I am having the same problem–CP 3.0 will bounce a couple of times but then not open. I have Java 8 and downloaded the Java Development Kit found on the Download page. I downloaded both before downloading CP. Suggestions?

Thanks,
Frederic


#29

I followed the discussion thread, by the way


#30

Likewise. I tried installing the latest version from the official website after installing java but the icon bounces a couple of times, then disappears


#31

this is despite installing homebrew and wxpython…


#32

Likewise, I have installed homebrew and wxpython alongside java 8 but a bouncing icon is all I can get. Is this specific to this version? I wouldn’t mind installing an older CellProfiler version to have it up and running on the Mac.


#33

Hi,

These all sound like Java errors- can you try installing the new 3.1.5 version and seeing if that works for you?