CP 2.1.1 crashes after a few cycles on Windows7

Hi,

I have a pipeline that runs fine on my laptop (OS X El Capitan).
I want to run it on a faster desktop computer. Here are its details:
Windows 7 Professional 64bit, Processor 3.5GHz, RAM 16GB
I installed on both CP2.1.1

On the Windows computer, the installation went fine and so did the beginning of the analysis, but after a few cycles of analysis the computer freezes completely. There’s no error message. I can only reboot it.
It looks like a memory issue.

Do you have any idea on this?

Many thanks for your help!

Hi,

Can you send us a Windows log for this event? windows.microsoft.com/en-us/wind … =windows-7

Just guessing, but you could also try:

  • lowering the number of cores/processors being used in CellProfiler Preferences.
  • A trunk build which may have fixed whatever bug you might be experiencing: http://cellprofiler.org/releases/

Thanks,
David

Thanks for your answer!

Here is the error log:

Log Name: System Source: Disk Date: 10/22/2015 9:16:10 PM Event ID: 11 Task Category: None Level: Error Keywords: Classic User: N/A Computer: ImagingStation Description: The driver detected a controller error on \Device\Harddisk2\DR2. Event Xml: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="Disk" /> <EventID Qualifiers="49156">11</EventID> <Level>2</Level> <Task>0</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2015-10-23T01:16:10.291326400Z" /> <EventRecordID>16843</EventRecordID> <Channel>System</Channel> <Computer>ImagingStation</Computer> <Security /> </System> <EventData> <Data>\Device\Harddisk2\DR2</Data> <Binary>0E01800001000000000000000B0004C003010000000000000000000000082D000000000000000000D277000000000000FFFFFFFF0600000058000000000000000000061208000010000000003C0000000000000000000000C08F5A1B80FAFFFF00000000000000002052321B80FAFFFF0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000</Binary> </EventData> </Event>

That is followed by a critical error:

Log Name: System Source: Microsoft-Windows-Kernel-Power Date: 10/22/2015 9:23:18 PM Event ID: 41 Task Category: (63) Level: Critical Keywords: (2) User: SYSTEM Computer: ImagingStation Description: The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly. Event Xml: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" /> <EventID>41</EventID> <Version>2</Version> <Level>1</Level> <Task>63</Task> <Opcode>0</Opcode> <Keywords>0x8000000000000002</Keywords> <TimeCreated SystemTime="2015-10-23T01:23:18.764818000Z" /> <EventRecordID>16854</EventRecordID> <Correlation /> <Execution ProcessID="4" ThreadID="8" /> <Channel>System</Channel> <Computer>ImagingStation</Computer> <Security UserID="S-1-5-18" /> </System> <EventData> <Data Name="BugcheckCode">0</Data> <Data Name="BugcheckParameter1">0x0</Data> <Data Name="BugcheckParameter2">0x0</Data> <Data Name="BugcheckParameter3">0x0</Data> <Data Name="BugcheckParameter4">0x0</Data> <Data Name="SleepInProgress">false</Data> <Data Name="PowerButtonTimestamp">0</Data> </EventData> </Event>

Hmm, hard to tell much from this event log. Did you have any success with my other suggestions?
David

Yes I have tried both of them. Lowering the number of runners (to 6 instead of 12) just increase the number of cycles before the computer freezes. This happens on both 2.1.1 and the 2.1.2. trunk build. It really looks like a memory leak.

I noticed this bug is not restricted to one computer but on several Windows 7 Professional 64bit desktops

Problem solved!

One kind of antivirus is messing up with CP: the ESET NOD32. I think the problem is that CellProfiler creates and deletes a lot of temporary files, and the antivirus is trying to keep track of them.
I uninstalled it and it works fine now.

Wow, thank you so much for reporting back your findings! This is good to know.

Yes, thanks for reporting this. You can typically also whitelist CellProfiler (or whatever your anti-virus calls it’s trusted list of apps) and stay otherwise safe.

Just chiming in here - I had the same problem, also windows 7 with ESET NOD32 antivirus - all pipelines I ran with all settings were hard freezing the entire computer.

Since uninstalling antivirus completely as amichaut did can be risky, I tried some other options. Unfortunately temporarily disabling the antivirus did not prevent the crash. However, rebooting the computer in safe mode so that the antivirus never starts did solve the problem.

I also tried added exclusions to the ESET realtime file monitoring. However, this also didn’t work. I added exclusions for the output folder, the cellprofiler program directory, and the cellprofiler temporary directory but it still crashed. Are there any other locations where CellProfiler might be writing temporary files that I should add exclusions for?

Thanks for reporting this @helliott. Your CP temp folder is found in the Preferences (On Mac, CellProfiler menu > Preferences…; On Windows, File > Preferences…) so that may be the culprit. Scroll down and you’ll see the Temporary folder. Assign it to wherever you like. We’ve not had issues in-house with Sophos antivirus, but in the years past whitelisting actually helped.

Hello,
I had the same problem. I upgraded ESET Endpoint antivirus to version 6.3.2016.1 and now is fine. I have tried already two pipelines with 3000 images and both finished succesfully. So hopefully the problem is solved.

Best,

Milan

@David_Logan

I don’t know why I get the attribute error shown when I run CP nightly. Kindly find the pipeline and image I used. Thanks.

NightlySample5.cppipe (14.8 KB)

@David_Logan @Fabba123

I watched this video http://www.mipar.us/watersheding.html and I’m pretty sure I can do the same thing with CP on my own images but I couldn’t get my pipeline to produce the same result…any suggestions as to what parameters in the modules to play with?

Thanks
Raphael