Counting Colonies: IdentifyPrimary Error

Hi!

I’m trying to use CP to count yeast colonies, with a pipeline based on the tutorial posted on the CP website (pipeline attached), and I’m having a real problem making an image mask that works. When the mask doesn’t precisely line up with the picture, the pipeline works fine, but when I modify it to line up perfectly (without changing the size), I get the following error:

Traceback (most recent call last):
File “/Applications/CellProfiler2.0.app/Contents/Resources/lib/python2.5/cellprofiler/pipeline.py”, line 309, in run
File “/Applications/CellProfiler2.0.app/Contents/Resources/lib/python2.5/cellprofiler/modules/identifyprimaryobjects.py”, line 725, in run
File “/Applications/CellProfiler2.0.app/Contents/Resources/lib/python2.5/cellprofiler/modules/identifyprimaryobjects.py”, line 1132, in filter_on_border
File “/Users/afraser/VENV254/src/scipy/scipy/sparse/coo.py”, line 177, in init
File “/Users/afraser/VENV254/src/scipy/scipy/sparse/coo.py”, line 213, in _check
ValueError: negative row index found

I don’t have photoshop, so I’m making the mask in ppt, maybe that’s part of the problem? Not sure.

Any help would be much appreciated!

Cheers,

Erin





SampleColonyScore_CP.cp (18.7 KB)

Hi Erin,

Could you tell me what module settings you are using to get it to line up perfectly?
-Mark

Hi Mark,

I’m using exactly the module settings in the sample pipeline I attached to the previous email, the only difference being that I loaded in the wrong mask accidentally. Attached is the mask that fits the image. I was getting the IdentifyPrimary error using the mask that I attached to the last message as well though.

Thanks for your reply,
Looking forward to hearing from you,

Erin