Convert SCN to TIFF with Bfconvert

I’m converting a SCN file with 53 series to OME-TIFF file using bfconvert with -noflat. When I use python-bioformats to load the new generated ome.tif file, I get only 1 series, which should be 53 instead. What could possibly be the case here? Thanks

Are the series in the original SCN file subresolutions? What does it look like if you drop the -noflat option, is there a particular reason for using it with this file?