Console opens when starting Fiji on Windows?

Hi @ctrueden, @stelfrich ,

I’m having an issue with the yesterday update of the imagej launcher on Windows:

I just downloaded a fresh Fiji and after updating it, it now opens with a command line window showing this error message:

When I close the command line window, Fiji closes. The command line window does not show up when running “ImageJ-win64.old.exe”. Can we please undo the rollout of the new launcher.exe until this issue is solved? Btw. what were the changes in the launcher? According to the github repository, there were no changes since Sept 2019.

These are the steps necessary to reproduce the issue:

  • Download and upack Fiji.
  • Update it once (It says there is a new updater)
  • Restart Fiji
  • Update it again (it comes with a new ImageJ-win64.exe and maaaany jar files updated)

I’m running on a recent Windows 10, have no special update sites activated and this is what Fiji says when double clicking the status bar:
image

Thanks!

Cheers,
Robert

1 Like

I just updated another Fiji and it looks like this:

… it is also frozen like that. Again, by replacing “imagej-win64.exe” with old “imagej-win64.old.exe” resolves the issue.

1 Like

Hi Robert,

I observed basically the same behavior. When I ran the update on my working install (wich is quite loaded), I got a couple of warnings in this console window. But the real problem arose when trying to rerun the update. I got an error message and that halted the update.

When I tried on a fresh install (downloaded in November 2019) I got the same message as you show. If you rerun Fiji as administrator, this error resolves. You still get the widows console, though.

I left a comment about this in the Fiji dev gitter channel as soon as I noticed. There’s also now a specific github tag for the issues that could arise with this big update, though I believe this specific thing has not been reported there.

Cheers!
Nico

1 Like

Hey @NicoDF,

thanks for confirming the issue. Sometimes it’s just my Fiji which does weird things. I created an issue on github as you suggested.

This introduces a security threat to the operating system. I must discourage everyone from doing this. Replacing the new .exe file with the old one is a less harmful workaround until the bug is fixed :wink:

I’m curious what Fiji tries to change in my system configuration though.

Thanks again!

Cheers,
Robert

2 Likes

Hi @haesleinhuepf,

Excellent, thanks!

Certainly! That was meant to be a diagnostic observation rather than a general advice for other users. Thanks for adding that remark.

I hope this can be fixed quickly.

Cheers!
Nico

2 Likes

@haesleinhuepf Could you please upload the working ImageJ-win64.exe (and probably also the old ImageJ-win32.exe) directly to the Java-8 update site, to minimize the number of affected installations? Thanks!

1 Like

Hey @ctrueden,

I just uploaded the former ImageJ-win64.exe. I also tried updating another Fiji installation and it doesn’t try to download the “new” exe anymore. Hence, I assume this issue is ok for the moment.

I also tried the win32.exe from the update site: It is not executable and gives an error:
image

I’ll try to find an older version of it (usually, I don’t have it installed) tomorrow and check with this one.

I’m happy to help testing potential new releases btw.

Cheers,
Robert

1 Like

Thanks a lot!

OK for the moment, yes. We really need to roll the launcher forward soon though, so that we can update the bundled Java to JBRSDK8.

Unfortunately, the Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5. message is not a bug in the launcher—it’s a bug in Java 8. I wonder why it works with the old launcher, though? I thought perhaps the old launcher hacked the registry to avoid the issue, but I couldn’t find any code in the history that does so—only code that queries (but does not modify) the registry.

Updating the bundled Java to 1.8.0_202 or later would fix the issue. But still, everyone with an existing Fiji installation bundling Java 1.8.0_172 would continue receiving this error message. -_-

See also:

1 Like

So this

sound like the solution to this

Do I understand this right?

Similar behaviour over here. Windows 10, 64 bit exe. Although I don’t notice different behaviour of my code… (yet?)

Where can I find an old exe? Can I just delete the current exe and then rename the old one?

Fred

Yes, if there is an imagej-win64.old.exe, just replace the new one with this one.

However, the current Fiji update shouldn’t ship the new exe anymore. May I ask when you updated your Fiji?

Thanks for your support!

Oops, I had a look, changed my file explorer view to get a Date modified column.

In Fiji.app/jars I see quite some files at around 1 Aug 13:20.

About backing up: can I just copy the complete Fiji.app folder, delete the existing one and the paste back the copy?

For many applications this does not work, probably because there is relevant info in other locations.

Fred

When I have invested heavily in a code, as right now :slight_smile: , I am normally cautious in doing application updates. Certainly when I don’t really know what I am doing.

But as I see very frequent notifications about updates, I almost never skipped one for Fiji. Up to now my code was not complaining…

Sometimes the alarm bell rang. Then I had to update ImageJ after an update of Fiji because some new functions could not be used anymore.

Does an update of Fiji sometimes downgrade the ImageJ part to a version before the latest?

Fred

This work pretty well with Fiji. :slightly_smiling_face:

2 Likes

Yes, the JBRSDK8 was built over 1.8.0_232 last I checked a few weeks ago.

Hi @Fred_ckx,

It can happen if you manually updated ImageJ to a different/alternative build than the one that’s shipped. In that case you’ll get a warning about a locally modified file (ij.jar) and you’ll be given the choice to keep it or replace it. I’ve seen that in an install where I regularly swap compiled versions. I’m not sure if that can ever happen if you have just updated to a more recent build (e.g. nightly build).

Cheers,
Nico

This happens to me regularly. But, I’m not well aware what I am doing… I just follow the suggestions: update or not.

Fortunately I can repair this always with Help / Update ImageJ

There is a lot to learn.

Fred

1 Like

Hi all, until now I have not been experiencing problems with the poorly behaving Fiji update. I have seen the extra command window and a somewhat different list of messages in the console, which I do not understand anyway :slight_smile: . So I have been using the update, untill this afternoon. I started to see annoying behaviour in the macro editor (using IJ1 macro language). I decided to use the ImageJ-win64.old.exe, which solved the problem.

I just report my experience, hoping that it might contribute to solve the problems:

I normally use the double forward slash // for commenting out single lines in the code.

When I want to comment out blocks of code I enclose the block like this: /* multiple lines of code here */

Since this afternoon these blocks of code were not “grayed out” anymore as before. It looks like these blocks of code were still not executed but my code becomes pretty unreadable by this. I simply can not see what is a comment and what is active code.

As said: problem solved by reverting to the ImageJ-win64.old.exe.

Maybe this adds something …

Fred

2 Likes

@Fred_ckx Thanks for reporting your findings. It’s helpful to hear these reports.

That said: I’m baffled by what you describe! Different ImageJ-win64.exe launchers somehow affecting behavior of the Script Editor’s syntax highlighting seems extremely unlikely. Could you please try to reproduce one more time with each launcher, just to be sure? Are you certain you had “IJ1 Macro” selected in the Languages menu both times? Were there other errors in syntax highlighting of IJ macros, or only multi-line comments? If you are able to reproduce, could you post a pair of working/not-working screenshots?

2 Likes

Hi @ctrueden,

The answer is, NO.

I opened the “affected” version of my code in my currently active app: ImageJ-win64.old.exe (modified date 11-Apr 19:42) and I see no problems. After closing I did the same with “the update” (ImageJ-win64.new.exe, modified date 1-Aug 13:20). I see the extra command window and the additional progress bar when starting the app. So, sure that it is the update.

However: I see no problems with the commented out code block !

Apparently there was some other reason for the unreadable code. I encounter it again, I will try to reproduce and then report it.

I had several code blocks within /* */ that had an appearance of active code. Then it is hard to judge the status of the code :slight_smile:

Issue closed, for now!

1 Like