Compatability issue between CellProfiler 3.1 and FIJI

Hi All,

I’ve noticed that the latest version of CellProfiler seems to change system environment variables, specifically those pertaining to Java. This is causing issues with Java-dependent applications, such as FIJI. Is this related to the fact that CellProfiler seems to now ship with it’s own local Java installation?

So, for example, I’m inclined to keep a single Java installation on my machines, for use by all installed applications. When I do so with FIJI, no problems are encountered. Following installation of the latest Cell Profiler however, FIJI throws an error on startup telling me it cannot locate jvm.dll.

Is this a known issue? Is there a reason why CellProfiler cannot just use whatever version of Java is preinstalled on the machine?



1 Like


This was a decision we made because there were a LOT LOT LOT of issues with CellProfiler 2.2 and 3.0 and Java- which can be shown if you search the forums for CellProfiler and Java. For better or for worse, it seemed to cause a tremendous number of issues (more than we’d anticipated) to make the users install Java.

We therefore decided to go back to what CP had done in 2.1.1 and before, which was package Java so that it wasn’t required for the user to go out and get Java (or use a particular version). For Mac we could set the Java environment variable just locally within the executable- as far as we could tell (and I’m happy to be corrected if there is a way!) we could not do something comparable for Windows, so we compromised by setting JAVA_HOME at a system level if and only if the user didn’t have it set already.

If this is causing an issue on a large scale (and if we’re breaking FIJI for all FIJI users, that’s definitely a problem), we’d definitely like to hear it- you should be able to resolve your particular issue by removing the JAVA_HOME environment variable from your settings. CP should then be able to use your system’s installed Java- please let me know if that doesn’t fix your FIJI issue and/or if CP no longer works when you do that.

I’m sorry to hear this- if it becomes an issue, we’ll definitely revisit remaking the build in a different way so this doesn’t continue to happen.


Hi @bcimini,

Thanks for the response.

I’ve followed your suggestion and removed the JAVA_HOME environment variable. This does indeed resolve the problem with FIJI, but unfortunately, CellProfiler no longer launches, giving the following error message:


1 Like

Ok, this is weird…

I uninstalled 3.1 and reinstalled 3.0, and all was well.

Then I installed 3.1 on top of 3.0, removed the environment variables mentioned above, and now everything seems to be fine?


I was wondering if there is any solution to this problem beyond removing JAVA_HOME from the environmental variables? Could it be related to the fact that I did not install CellProfiler to a default location?


Did you install it off the C drive? CellProfiler currently only works when installed on your main drive.


I tried installing CP on an Amazon “Workspace” computer. I don’t have C drive access. I tried installing to the D drive, but I am getting the same “Failed to execute script CellProfiler” error mentioned above. Any thoughts?

Thanks for your time! John

1 Like

I would like to know the answer also if it is available.

Thank all of you for helping fix this. I appreciate it greatly.

Hi guys,

The installation on a non C:\ directory is a known issue; you can try setting the temp variable in the command line as that user does, that allowed me to run CellProfiler on a non C:\ directory.