Colab not creating labeled videos

I’m using colab (latest_Colab_TrainNetwork_VideoAnalysis.ipynb) with project file mounted in my google drive. Labeling is done outside COLAB with the GUI; I’m able to generate train network, the plotted trajectories of points look good, and the generated .hd5 files are in the appropriate /videos folder of the project directory. However, the last cell of colab will not create labeled videos, no errors are thrown, it just does not progress, and the cell stops running (I can re-initialize it, it’s not timing out). See below (I’ve just got two videos in this batch):

Any suggestions on what could be giving me this problem? Files are .m4v

i’m not sure I understand the error, as it looks like the video is indeed created; is it not saving into your drive folder correctly?

This is where the file should be created:

Thank you so much for the quick response. Yes, I am looking in the ‘video’ folder, but there are no new videos created there. The original videos (.m4v) are there, but no new labeled videos (no .mp4 videos).

I couldn’t tell if it’s an issue that the video isn’t being created or not being saved. There’s no error message being thrown so not sure how to proceed. What my ‘videos’ directory looks like:

And for what it’s worth, the plotted trajectories look reasonable (so I don’t believe it’s the case that the network trained on no data; some related threads here suggested to check that). ie:
image

Thank you so much for the quick response and any guidance of what to check (I’ve used this COLAB notebook successfully in the past, so really stumped as to what I’m doing differently).

No problem, happy to help. It is indeed odd … any chance the drive is full or something like this?

The presence of the H5 file is great too; looks like everything worked. The create_labeled_video step doen’t use the GPU actually, so if you want to download and try locally again, that would be useful.

Note, you can also load the h5 files and adjust the plots, etc in this notebook: https://github.com/DeepLabCut/DLCutils/blob/master/Demo_loadandanalyzeDLCdata.ipynb

So, I don’t know what the problem was. I converted my original video to .avi and repeated the whole process… now it’s creating videos. Wish I had come up with a more satisfying reason why it wasn’t writing labeled videos with the original .m4v.

Thanks again for the prompt and helpful responses!

no problem! Still puzzling, but glad you got solved :slight_smile: