ClearVolume Fiji + CUDA

Dear all (@fjug, @skalarproduktraum, …) ,

clearVolume does not recognize the CUDA drivers and uses openGL instead.

Current installs:
NVIDIA KD4200
CUDA toolkit 10.2
Windows 10
clearVolume 1.4.1

I get the following message.

ClearGLWindow: GLProfile[GL4/GL4.hw]
1.0
1.0
1.0
WindowsNov 21, 2019 4:17:02 PM org.bridj.BridJ log
INFO: Library not found : atiocl64
Nov 21, 2019 4:17:02 PM org.bridj.BridJ log
INFO: Library not found : amdocl64
Nov 21, 2019 4:17:02 PM org.bridj.BridJ log
INFO: Library not found : atiocl32
Nov 21, 2019 4:17:02 PM org.bridj.BridJ log
INFO: Library not found : atiocl
Nov 21, 2019 4:17:02 PM org.bridj.BridJ log
INFO: Library not found : amdocl32
Nov 21, 2019 4:17:02 PM org.bridj.BridJ log
INFO: Library not found : amdocl
 --> Using backend: ClearCLBackendJOCL
clearcl.backend.jocl.ClearCLBackendJOCL@1a810779

Antonio

1 Like

As far as I remember there is not CUDA support any more. It was painful to drag both along, and the OpenCL was not slower or worse.
@skalarproduktraum @royerloic – please update me if this is not actually true any more.

@apoliti – Despite OpenCL being used, does ClearVolume start up and show what it should the way it should?

Best,
Florian

1 Like

Hi Florian,
with openCL it works. However, I realized that when playing a timelapse I get a overlay of images.
One see several time-points in one image.
I thought that using CUDA could help this issue.

1 Like

1 Like

These are two consecutive points of a movie. I hope that you can see that in the second image the points duplicate (I can find a better example if needed). In fact this is due to an overlay of consecutive time points. Depending on the movie it can be more than 2 time points. The original file is 980 MB and my graphic card has 4GB so I don’t think that it is due to a lack of memory.

I had this issue from the first time I was using clearVolume (8 months ago) with different versions of imageJ, clearVolume, and PC. With this bug it makes it difficult to use clearVolume for creating a movie of a time lapse.

1 Like

Yes, indeed… I understand that this in not wanted.
From my memory of how this is implemented it puzzles me how this is even possible…
@royerloic @skalarproduktraum, do you have an idea what is going on?

Rest of world: do you have similar problems???
Does this only happen after clicking the play button, or also when you manually go to different time points (via the slider)???

1 Like

Hi!

Unfortunately we have a long-standing bug in the multi-pass rendering that causes multiple render passes to get merged together but with different transforms. The easy fix for this is to simply toggle off the multipass rendering using the key ‘m’. The rendering is slower (which you can tune by adjusting ray-casting quality = step length) but you should have no more issues.

We really need to fix this but non of us has had the time to do it unfortunately.

Hope this helps.

Loic

1 Like

Hi @apoliti & @fjug & @royerloic ,

just to clarify and get everyone on the same page: AFAIK ClearVolume doesn’t run on CUDA. Instead, it uses OpenCL and ClearCL as layer in between. The error message shown above results from a bug in a dependency (bridj) which we cannot easily fix but hide. CLIJ is built on top of the same infrastructure. There, the error is hidden by these two lines: 1 2. If you think this workaround is worth a copy, I’m happy to file a PR if you point me to the repository where the ClearVolume code lives at the moment.

Suggestion: Can we turn multipass-rendering off by default? At least on my Windows systems I perceive this rendering issue also for a long time…

Cheers,
Robert

Hello Loic,
In Fiji the key ‘m’ does not seem to do much. I don’t get a feedback that something is happening and the issue remains.
@haesleinhuepf: Thanks for the clarification. With the current warnings it seems that clearVolume wants to use CUDA but is not finding it. I think in one past version it was using CUDA.

antonio

1 Like

it happens also through the slider. In fact it is very persistent and in some cases in never shows the correct image without the time overlay.

1 Like

Somehow the behavior is a little confusing.
If I start to play the movie, make a pause, and press ‘m’ no changes.
If I press ‘m’ just after the start of CV then there is no overlay of time-points. I can toggle multipass back again, but i can’t disable it anymore.

Would be great if there is a label to indicate in the menu if multipass is on or off. Also the suggestion to disable it by default is good. Usually, I was returning to imaris to create a movie.

1 Like